.NET Framework bei Exchange Updates berücksichtigen

Kleiner Tipp am Rande da die Frage schon häufiger gestellt wurde:

Muss ich bei der Installation von Exchange Updates (CUs) auch .NET Framework berücksichtigen?

Einfache Antwort: Ja!

Hier die etwas ausführlichere Antwort:

Nicht unterstützte NET Framework Versionen in Verbindung mit Exchange Server können durchaus problematisch sein, wie sich in der Vergangenheit schon gezeigt hat:

https://www.frankysweb.de/net-framework-4-6-1-nicht-auf-exchange-servern-installieren/

Die NET Framework Version muss aber auch bei der Aktualisierung von älteren Exchange Versionsständen berücksichtigt werden. Hier ein kleines Beispiel:

Normalerweise enthalten Exchange CUs alle Patches der vorangegangen Versionen, so ist es in der Theorie durchaus möglich einen Exchange 2016 Server mit CU1 zu installieren und direkt auf CU5 zu aktualisieren. Es muss also nicht erst CU2, dann CU3, danach CU4 und schlussendlich CU5 installiert werden.

Soweit die Theorie, nun zur Praxis:

Stellen wir uns einen Exchange 2016 Server mit installiertem CU3 vor, auf dem Server befindet sich auch NET Framework 4.5.2. Hier kann beispielsweise nicht direkt auf das CU5 aktualisiert werden. Hintergrund CU4 erfordert mindestens NET Framework 4.6.1, dieses wird aber nicht von CU3 unterstützt. Hier muss also zunächst auf CU4 aktualisiert werden, dann NET Framework auf Version 4.6.2 aktualisiert werden und erst danach kann auf CU5 aktualisiert werden.

.NET Framework bei Exchange Updates berücksichtigen

Quelle: Exchange 2016 prerequisites

Gleiches Spielchen für Exchange 2013:

Wenn der Exchange Server ein Patchlevel vor CU15 hat, kann nicht direkt auf CU16 aktualisiert werden, Hier muss zunächst das CU15 installiert werden, dann NET Framework aktualisiert werden und erst danach kann auf CU16 aktualisiert werden.

Diese Art der NET Framework Abhängigkeiten finden sich auch in anderen Konstellationen, denn manche Exchange CUs unterstützen nicht die erforderlich NET Framework Version der aktuelleren CUs. Hier muss also zunächst auf ein älteres CU aktualisiert werden, damit die erforderlich NET Version installiert werden kann.

Aktuell zum Beispiel noch die Empfehlung kein NET Framework 4.7 auf Exchange Servern zu installieren:

Man sollte also vor der Installation von Exchange CUs auch immer einen Blick auf die NET Framework Version werfen.

Hier finden sich die aktuell unterstützen .NET Framework Versionen:

.NET Framework bei Exchange Updates berücksichtigen

Quelle: Exchange Server Supportability Matrix

11 Replies to “.NET Framework bei Exchange Updates berücksichtigen”

  1. Ich hatte auf einem Exchange 2013 CU3 durch Windows Update .NET 4.7. Im Netz fand ich der Ratschlag dieses zu deinstallieren und (vor dem Update) die freigegebene Version zu installieren. Bei mir ging das nach hinten los, nach der Deinstallation war mein IIS total im Eimer. Nach 3 Stunden erfolgloser Suche hab ich das Backup des Servers wiederhergestellt.

  2. Ich habe mit .Net 4.7 auch EX2013 die gleiche Erfahrung wie Christian machen müssen. Nach der Installation des entsprechenden Updates ging gar nichts mehr und die VM wurde schließlich aus einem Backup wiederhergestellt.

  3. Wir haben diverse Server mit Exchange 2010 am laufen. Dort dürfte überall .NET 4.6.1 laufen, obwohl das in der Matrix nicht als unterstützt drin steht.

    Gibt es bekannte Probleme in dieser Konstellation?

  4. Danke für den Artikel.
    Ich habe am Wochenende das Update von CU3 –> CU4 –> CU6 vollzogen. Hat alles geklappt mit dem .NET Updates.
    Einzig mein OWA war danach nicht erreichbar dank Fehler 1309 / 3005 (Zertifikat neu erstellen / Zuweisen).
    Funktioniert nun wieder alles wie gewohnt.

    Gruss,
    Michael

  5. Hallo, die hier beschriebene Vorgehensweise ist falsch. Mehrere CUs nacheinander zu deplyoen ist nicht notwendig.

  6. Hallo Ralf,
    im Normalfall ist es nicht notwendig, jedoch kann es Abhängigkeiten zur .NET Version geben, siehe hier:

    Exchange 2016 CU5 and later require .NET Framework 4.6.2. Upgrade your servers to .NET Framework 4.6.2 before you install Exchange 2016 CU5 or you’ll receive an error. If .NET Framework 4.5.2 is installed on your Exchange servers, upgrade your servers to Exchange 2016 CU4 before installing .NET Framework 4.6.2.
    Quelle: https://technet.microsoft.com/de-de/library/bb691354(v=exchg.160).aspx

    oder auch hier:

    …Ideally Exchange 2013 servers will already be on CU15, and Exchange 2016 servers will already be on CU4. If this is the case then .NET can be upgraded prior to installing Exchange 2013 CU16 and Exchange 2016 CU5. However if this is not the case then you cannot upgrade directly to the latest CU, you must:
    •Upgrade to Exchange 2013 CU15 or Exchange 2016 CU4
    •Only then perform the .NET upgrade to 4.6.2
    •Then upgrade to Exchange 2013 CU16 or Exchange 2016 CU5

    Quelle: https://blogs.technet.microsoft.com/rmilne/2017/03/27/exchange-2013-cu16-and-exchange-2016-cu5-net-framework-requirement/

    In diesem Fall ist es notwendig zuerst bis zu einem bestimmten CU zu aktualisieren, danach das .NET Update durchzuführen um dann das letzte CU zu installieren.
    Gruß,
    Frank

  7. Leider ist auch der Blog Post falsch: https://blogs.technet.microsoft.com/rmilne/2017/03/27/exchange-2013-cu16-and-exchange-2016-cu5-net-framework-requirement/

    Die Vorgehensweise steht im Prinzip hier: https://technet.microsoft.com/de-de/library/bb691354(v=exchg.160)

    Beispiel: Du hast CU3 installiert.
    1. Upgrade auf .Net 4.6.2
    2. Reboot
    3. Update auf CU6
    fertig.
    Natürlich ist die Kombination CU3/.Net 4.6.2 nicht supported, wenn aber unmittelbar danach CU5/6 installiert wird ist das völlig ok.

  8. Hallo Ralf,

    im von dir verlinkten Artikel steht es anders:

    Important:
    Exchange 2016 CU5 and later require .NET Framework 4.6.2. Upgrade your servers to .NET Framework 4.6.2 before you install Exchange 2016 CU5 or you’ll receive an error. If .NET Framework 4.5.2 is installed on your Exchange servers, upgrade your servers to Exchange 2016 CU4 before installing .NET Framework 4.6.2.

    Was bedeuten würde: CU3 + .Net 4.5.2 -> Update auf CU4 + .NET 4.6.2 -> Update auf CU5

    Gruß, Frank

  9. Also ich habe hier einen Exchange Server 2010 SP3 Rollup 18 mit .Net Framework 4.7 und keinerlei Probleme oder Fehlermeldungen.

    Das muss Microsoft unbedingt besser in den Griff kriegen, es kann nicht sein das man CU1 – CU5 nacheinander installieren muss und Microsoft die Update als kumulativ propagiert.

  10. Hallo,

    kann man sich irgendwo noch ältere Exchange 2013 CUs herunterladen?
    Alle M$ Links verweisen auf das aktuellste CU.

    Ein vorhandener Exchange 2013 (CU4) soll auf CU17 aktualisiert werden.

  11. Hallo zusammen,

    Wir haben Windows 2008 R2 mit Exchange 2010 CU18.
    Auch bei uns kein Problem mit .Net 4.7.

    Beste Grüße
    Michael

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.