Exchange Migration: Probleme mit der Outlook Verbindung

Dieser kleine Artikel soll die häufigsten Ursachen für Probleme mit der Outlook Verbindung mit Exchange während der Migration auflisten. Häufig kommt es zu Verbindungsproblemen nachdem ein Postfach auf eine neuere Exchange Version verschoben wurde. Outlook bringt dann gerne eine der folgenden Meldungen:

Der Microsoft Exchange-Administrator hat eine Änderung durchgeführt, die einen Neustart von Outlook erfordert.

Diese Meldung kann hei jedem Outlook Start auftreten, eine Verbindung zum Postfach ist dann nicht mehr möglich:

Exchange Migration: Probleme mit der Outlook Verbindung

Die Aktion kann nicht abgeschlossen werden. Es steht keine Verbindung mit Microsoft Exchange zur Verfügung. Outlook muss im Onlinemoduls oder verbunden sein, um diesen Vorgang abzuschließen

Diese Meldung tritt beim Einrichten neuer Profile auf, das Einrichten des Profils ist nicht möglich:

Exchange Migration: Probleme mit der Outlook Verbindung

Oder auch einfach diese Meldung von Outlook 2019:

Da hat etwas nicht geklappt.

Exchange Migration: Probleme mit der Outlook Verbindung

Ich würde in diesem Artikel gerne die häufigsten Ursachen sammeln, gerne nehme ich weitere Ursachen / Probleme per Mail oder als Kommentar entgegen und werde diesen Artikel dann aktualisieren.

Autodiscover und DNS

Nachdem die neuen Exchange Server installiert und konfiguriert wurden, müssen die DNS-Einträge für Autodiscover auf die neuen Exchange Server verweisen. Hier kommt es oft zu Problemen, wenn ein Postfach zu neuen Exchange Servern verschoben wird, die Autodiscover DNS Einträge aber noch auf die alten Server verweisen. Hier ein Beispiel, welches bei der Migration von Exchange 2010 zu Exchange 2016 auftreten kann (aber auch bei anderen Versionen):

In diesem Fall zeigt der HOST-A Record autodiscover.frankysweblab.de auf die IP 192.168.200.14, welches die IP des Exchange Servers EX1 ist (rot). In diesem Fall ist EX2 der Exchange Server mit der neueren Version (blau):

Exchange Migration: Probleme mit der Outlook Verbindung

Der DNS-Eintrag für Autodiscover muss hier also auf den neuen Exchange Server verweisen:

Exchange Migration: Probleme mit der Outlook Verbindung

Gleiches gilt auch für die SRV-Records (wenn existent):

Exchange Migration: Probleme mit der Outlook Verbindung

Auch SRV-Records müssen auf den Exchange Server mit der neueren Version zeigen. In diesem Beispiel wurde also die IP für den HOST-A autodisocver.frankysweblab.de auf 192.168.200.15 (IP neuer Exchange Server) und der SRV-Record auf den Host autodiscover.frankysweblab.de geändert. Somit verweist Autodiscover auf die Exchange Version zu der migriert werden soll:

Exchange Migration: Probleme mit der Outlook Verbindung

Hier gilt es auch an die externen DNS Einträge zu denken.

Outlook 2010 und MAPIoverHTTP

In vielen Unternehmen ist noch Outlook 2010 im Einsatz. Mit Exchange 2013 wurde das Protokoll MAPIoverHTTP eingeführt welches RPCoverHTTP ersetzt. Auch wenn RPCoverHTTP noch unterstützt wird, gibt es mit aktivierten MAPIoverHTTP meistens Probleme mit Outlook 2010.

Outlook 2010 unterstützt MAPIoverHTTP erst mit einem Update (KB2965295), dieses Update erfordert das Service Pack 2 für Office 2010. Damit MAPIoverHTTP mit Outlook 2010 funktioniert, muss also das Service Pack 2 für Office und das KB2965295 installiert sein.

Hier einmal die entsprechenden Download Links:

Die Updates sollten also vor dem Verschieben der Postfächer installiert werden, damit Outlook 2010 eine Verbindung zu Exchange 2013/2016 mit aktivierten MAPIoverHTTP herstellen kann.

Für Outlook 2013 und höher sind keine speziellen Updates nötig, jedoch sollten diese natürlich auch auf einem aktuellen Stand sein.

Autodiscover Redirects

Ein weiteres Problem sind die Autodiscover Redirects der Exchange Server, auch hier kann es zu Verbindungsproblemen mit Outlook kommen:

After the mailbox move is completed, Exchange Server 2013 or 2016 continues to proxy the autodiscover request to Exchange Server 2010. Exchange Server 2010 responds with a 302 redirect back to Exchange Server 2013 or 2016 (depending on the upgrade).

Dieses Problem ist in dem folgenden Microsoft Artikel beschrieben:

Das manuelle Neustarten des Application Pools ist aber meist keine Lösung, gerade wenn viele Postfächer über einen längeren Zeitraum verschoben werden. Hier kann man sich mit einem Neustartintervall des Application Pools behelfen. Im IIS-Manager lässt sich ein Neustartintervall für den “MSExchangeAutodiscoverAppPool” festlegen:

Exchange Migration: Probleme mit der Outlook Verbindung

Mit einem Neustart Intervall von 5 Minuten, bleibt ein Postfach also nur maximal 5 Minuten getrennt und es muss kein manueller Neustart des Application Pools durchgeführt werden:

Exchange Migration: Probleme mit der Outlook Verbindung

Nachdem alle Postfächer verschoben wurden, kann diese Einstellung wieder rückgängig gemacht werden.

Exchange URLs

Auch falsch konfigurierte URLs für die virtuellen Verzeichnisse im des Exchange Servers können Verbindungsprobleme mit Outlook verursachen. Beispielsweise können Tippfehler in den URLs zu einer fehlerhaften Namensauslösung führen und damit die Verbindung von Outlook zu Exchange stören.

Die Konfiguration der virtuellen Verzeichnisse ist hier beschrieben:

Die Hostnamen in den URLs müssen via DNS entsprechend auflösbar sein. Die Virtuellen Verzeichnisse können auch in der EAC verwaltet werden:

Exchange Migration: Probleme mit der Outlook Verbindung

Der Hostname für Outlook Anywhere findet sich hier:

Exchange Migration: Probleme mit der Outlook Verbindung

Die URL für Autodiscover kann allerdings nur über die Exchange Management Shell verwaltet werden:

Get-ClientAccessService | fl name,autodiscover*
Set-ClientAccessService -Identity EXCHANGE -AutoDiscoverServiceInternalUri "https://autodiscover.frankysweb.de/Autodiscover/Autodiscover.xml"

Exchange Migration: Probleme mit der Outlook Verbindung

Mit dem Befehl “Set-ClientAccessService” lässt sich die URL entsprechend anpassen.

12 Kommentare zu “Exchange Migration: Probleme mit der Outlook Verbindung”

  1. Hallo Frank,

    wir haben Probleme mit Outlook 2019 und mit Vollzugriff eingebunden Postfächer.
    Postfächer sind bei mehreren Benutzern mit Vollzugriff eingerichtet.

    exchange 2016/exchange 2019 und outlook 2019, am server ist vollzugriff recht vergeben, Postfächer sind im Outlook
    vorhanden, syncronisieren jedoch nicht korrekt.
    Immer wieder ist das Postfach getrennt, dann wieder verbunden, es kommt auch ab und an eine Meldung:
    Auf diese Ordner usw. kann nicht zugegriffen werden, der Administrator hat ein Limit konfiguriert oder so ähnlich.

    Gibt es hier bekannte Probleme mit Outlook 2019?

    LG

    Sascha

  2. Hi Frank!
    Was Kevin Schley schreibt, hatten wir auch häufig. War nur beim ersten Mal ein Problem, da wir natürlich unrund geworden sind, wie alles verschoben und richtig gestellt war und trotzdem noch nicht möglich war, mit 2016 zu arbeiten. Nach 30 Min nachdem der Batch verschoben wurde, hat dann alles funktioniert.

    Danke auch Frank für den tollen Artikel.
    Eine Frage habe ich dazu, weil ich lese, dass der SRV Eintrag auch umgeändert gehört: Falls ein SRV-Eintrag war mit dem alten, gehörts auf neue, verstanden. Wenn aber keiner da war und es sind die Domains
    .Domain.de
    owa.domain.de
    autodiscover.domain.de
    im Zertifikat enthalten, benötigt man keinen SRV-Eintrag.
    Bisher hat ein SRV-Eintrag im Outlook nur dazu geführt, dass eine zusätzliche Meldung aufgeschienen ist, ob man der URL für die Autokonfiguration trauen soll oder sowas (mit einer Checkbox, dass die nicht mehr kommt). Aber solche Meldungen verwirren. Die gibts auch noch mit Outlook2016.

    Somit meine Frage: SRV-Eintrag nur wenn einer war und nicht dennoch zusätzlich?
    Möchte die Outlook-Fenster eigentlich vermeiden.
    liebe Grüße aus Wien!

    1. Hallo Mr Buabe,
      wenn es bisher keinen SRV Eintrag gegeben hat, musst du ihn nicht extra anlegen. Dies ist meist auch nur für zusätzliche Domains nötig, die keinen HOST-A Eintrag besitzen und somit auch nicht als SAN auf dem Zertifikat stehen. In der Standardeinstellung fragt Outlook nach, ob die Umleitung via SRV Eintrag zugelassen werden soll. Dies ist aber eine einmalige Meldung und lässt sich auch in der Registry abschalten.
      Gruß,
      Frank

  3. Hi zusammen,
    Ich hatte dieses verhalten ebenfalls bereits bei diversen Exchange Migrationen.
    Outlook kann keine Verbindung mehr mit dem migrierten Postfach herstellen. (DNS etc. sind alle korrekt eingerichtet)

    Die Lösung in bisher jedem Fall war, nach Abschluss des Migrations Batch einfach zu warten.
    Nach ca. 20 bis max 60 min kann sich Outlook wieder ganz normal verbinden.
    Dieses verhalten konnte ich jetzt bei ca. 4x Exchange Migrationen 2010 -> 2016 beobachten.
    Zukünftige Postfach Finalisierungen werden bei uns seither immer nach der Regulären Arbeitszeit des Kunden ausgeführt.

    Einer eine Idee woran das liegt und was da genau passiert?
    Grüße

  4. Hallo Frank,

    hat hier jemand meine Gedanken gelesen… :-)

    Wir beginnen gerade die Postfächer von unserem Ex2010 auf das neue Ex2016 DAG zu ziehen. Und genau mit diesen Problem kämpfe ich gerade. Manche Postfächer brauchen ewig bis sie sich wieder per Outlook verbinden können.

    Dann teste ich morgen gleich mal den AppPool Neustart und checken SRV Eintrag.

    Danke

    Andreas

  5. Beim script hat sich in Zeile zwei ein copy-paste Teufel eingeschlichen.
    Da steht:
    Set-ClientAccessService -Identity EXCHANGE -AutoDiscoverServiceInternalUri „<a href="https://autodisc
    und so weiter. Der Teil gehört weg.
    Toll wenn einem Webtools mit ihren Automatismen so schön in den Fuß schießen.

    1. Toll hier hier hat mir das webtool ebenfall „geholfen“:
      Der korrekte Satz lautet (hier mit Spaces damit es nicht werinterpretiert wird):
      Der Teil mit dem weblink, also von bis muss weg.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.