Exchange 2019: März Update könnte Probleme mit der Outlook Suche verursachen

Gestern wurden Sicherheitsupdates für Exchange Server 2016 und Exchange Server 2019 veröffentlicht. In Verbindung mit Outlook und Exchange Server 2019 häufen sich nun Meldungen über Probleme mit der Suche. Im Exchange Team Blog und auch in den Kommentaren zu meinem Beitrag berichten Admins über die Probleme.

Bei der Suche kommt es scheinbar zu der Fehlermeldung „We’re having trouble fetching results from the server…“ bzw. „Da hat etwas nicht geklappt, und ihre Suche konnte nicht abgeschlossen werden.“, wie in Screenshots auf dem Exchange Team Blog zu sehen ist:

Exchange 2019: März Update könnte für Probleme mit der Outlook Suche verursachen
Exchange 2019: März Update könnte für Probleme mit der Outlook Suche verursachen
Exchange 2019: März Update könnte für Probleme mit der Outlook Suche verursachen

Die Suchprobleme scheinen unabhängig von der Outlook Version bzw. auch unabhängig vom Outlook Modus (Cache Mode / Online Mode) zu sein. In einem Kommentar im Exchange Team Blog werden zwei Registry Keys als Workaround vorgeschlagen, was scheinbar in einem Fall geholfen hat:

Exchange 2019: März Update könnte für Probleme mit der Outlook Suche verursachen

Von Microsoft wurde das Problem bisher nicht offiziell bestätigt. Unabhängig vom möglichen Suchproblem enthält das März Sicherheitsupdate zwei bekannte Probleme:

Auf dem Exchange Team Blog bringt es ein Kommentator auf den Punkt:

Die Outlook Suche ist bei Benutzern eine der Kernfunktionalitäten, bei OWA Benutzern muss natürlich auch das Anzeigen und Runterladen von Anhängen funktionieren. Das temporäre Abschalten der Download Domains könnte man noch verkraften, aber eine defekte Outlook Suche würde für viele Anrufe beim Helpdesk sorgen.

Meine Empfehlung ist es daher, zunächst einmal die Installation des Updates zu verschieben, bis hier weitere Informationen vorliegen. Ich werde diesen Artikel aktualisieren, sobald ich Neuigkeiten mit bekomme. Wenn ihr ähnliche Probleme nach der Installation des Updates feststellen könnt, schreibt es gerne in die Kommentare.

Update 14.03.2024: Microsoft hat mittlerweile bestätigt, dass es zu den beschriebenen Problemen kommen kann. Auf dem Exchange Team Blog gibt es nun einen entsprechenden Hinweis zum Update. Wer das Update installiert hat und nun die Probleme mit der Suche hat, soll die gezeigten Registry Einträge am Outlook Client setzen:

Key: HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Search
Value 1: DisableServerAssistedSearch
Value 2: DisableServerAssistedSuggestions
Value type: REG_DWORD
Value: 1

Dies stellt aber nur einen Workaround dar. An einem Fix für das Problem wird noch gearbeitet.

Update: 19.03.2024: Bisher gibt es noch keine weiteren Informationen. Microsoft arbeitet noch an einem Fix und empfiehlt die beiden Registry Keys als Workaround:

Update 02.04.2024: Bisher gibt es noch kein neues Update welches die Probleme behebt. Es kommen aber neue Probleme dazu. Zwischenzeitlich wurde der Bug mit den falsch gekennzeichnet Mails bestätigt, sowie Probleme mit diversen Add-Ins:

  • After installation of the March 2024 SU, newly received messages might show yellow envelope icon in Outlook client, no matter the read status of the message. This issue is cosmetic.
  • Certain add-ins (such as My Templates) might not work properly after March 2024 SU is installed.

Im Exchange Team Blog berichten auch viele Anwender von Problemen mit der Outlook Mobile App. Auch scheint es Probleme mit geteilten Kalendern zu geben. Leider muss weiter auf ein neues Update gewartet werden.

46 Gedanken zu „Exchange 2019: März Update könnte Probleme mit der Outlook Suche verursachen“

  1. leider bisher immer noch keinen fix seitens Microsoft ?!

    Update wurde wieder deinstalliert, hilft aber auch nicht. bei paar Postfächer geht die Suche komischerweise aber.

    Die Registry Keys sind auch keine Lösung für mich, da es sich um eine Terminal Server Umgebung handelt kann ich die lokale Indizierung nicht nutzen, aufgrund von der großen Anzahl an Mails die dann da indiziert werden müssen.

    Antworten
  2. Hallo,

    bei uns hängt sich Outlook nach beenden der Suche für ein paar Sekunden auf. Kann dann aber wieder genutzt werden. Nervt, ist jetzt aber nicht kriegsentscheidend. Gibt es hier eventuell ne Lösung

    Antworten
  3. Ich bin gespannt ob vor Ostern noch ein Update raus kommt wo die Probleme gefixt sind. Ich will das ungern über Ostern ungepatched lassen. Sonst muss ich wohl das potentiell kleinere Übel nehmen und mit der „etwas weniger gefährlichen Lücke“ und dem Mailmarkierproblem von gelesenen Mails leben :/

    Antworten
    • Das Update kommt natürlich pünktlich zum ersten April und pulverisiert alle On-Prem Exchange Server zu Staub, damit endlich alle gezwungen sind in die cLoUd umzusiedeln ;)

      Antworten
  4. im ExchBlog schreibt einer:

    The outlook issue is fixed, for some reason the patch removed windows auth from mapi in the backend.

    Eventuell einen Blick wert ?

    Antworten
    • Da ging es aber nicht um das Suchproblem. Derjenige hatte das Problem, dass Outlook immer nach Benutzername und Passwort gefragt hatte. Die Kommentarfunktion in dem Exchange Blog ist hier mMn etwas unübersichtlich.

      Antworten
      • Das würde ich unterschreiben. Aber soviel besser ist es hier auch nicht. ;) Vor allem weil sich kaum einer mal die Mühe macht, die Kommentare auch der Reihe nach zu lesen.

        Antworten
  5. Ich muss mal wieder ne „dumme“ Frage stellen. Wenn ich Download Domains nicht konfiguriere oder deaktiviere, funktioniert dann der Download über OWA wieder ?

    Antworten
      • Hallo NorbertFe, so ein Satz mit X, das war wohl nichts. Habe das SU Update nun installiert.

        In OWA kommt folgende Fehlermeldung beim Öffnen von Anlagen „Es ist ein unbekannter Fehler aufgetreten“

        der Healthchecker sagt „Download Domains are configured und zeigt es rot an“

        also müssen diese nun per PowerShell deaktiviert werden?

        Antworten
        • Ja, so wie es auch im Exchange Blog verlinkt ist. Solange Download Domains aktiv sind wird das nicht mehr funktionieren. Du musst sie mit den entsprechenden Kommandos in der Exchange Shell deaktivieren.
          Aber ernsthaft, liest du die Release Notes nicht vor der Installation? Das Problem und der Workaround (ich möchte es nicht Lösung nennen) war von Anfang an beschrieben.

  6. Exch 2019 CU13 mit aktuellem März Security Update auf Server 2019.
    Suche auf den Clients funktioniert nicht.

    Ich mach derweil nichts, der Kunde soll ruhig auch einen Zorn auf Microsoft bekommen.
    Die Unfähigkeit dieses Unternehmens ist einfach nur unbeschreiblich… Man möchte meinen Exch ist eine Freeware mit 2 Hobby Programmiere im Hintergrund.

    Antworten
  7. Exchange 2019 mit Outlook 2016 bisher keine Probleme mit der Suche.

    Nur dieses Brief Symbol bei manchen Mails. Da fragen die User natürlich sofort nach was das jetzt ist und mimimi….
    Ist das schon ein bestätigter „Bug“ oder nicht? Finde dazu nicht wirklich was.
    Und wie ist das „System“ hinter dem Symbol? Ich erkenne bisher keines.

    Antworten
    • Bisher zusammengereimt haben wir uns:

      => Symbol da bei intern zu intern
      => und es geht weg sobald mal eine andere „Symbol“-Aktion ausgeführt hat (weiterleiten, antworten)

      Also scheint es für uns im ersten Moment einfach ein „Bug“ zu sein, dass nach öffnen der Mail überhaupt das Briefsymbol noch angezeigt wird und nicht wie bisher ausgeblendet wird.

      Antworten
      • Hm. Bei uns nicht. Wirkt eher zufällig. Auch in den Gesendeten Elementen haben es sowohl interne als auch externe gemischt.
        OK. Wir betrachten das auch erstmal als „optischen Bug“ :)

        Antworten
      • Guten Morgen,

        das Phänomen tritt bei uns auch auf.
        Briefsymbol im Outlook bei eigehenden internen Mails. (Im Postausgang nicht)
        Exchange 2016 + Server 2016.
        Die User fragen natürlich nach was das soll und die IT hat keine Antwort, sehr ärgerlich sowas.

        Antworten
        • „Die User fragen natürlich nach was das soll und die IT hat keine Antwort, sehr ärgerlich sowas.“

          Ja so gehts mir auch *gg*

          Aber bei uns ist es auf jeden Fall bei allen internen Mails die nach dem Update gemacht wurden im Posteingang in der Spalte Symbol da. (EX2016+Server2016)

  8. Verstehe ich das richtig und die beiden Registry-Keys schalten die Suche auf dem Server einfach nur ab, so dass Outlook nur noch lokal in der ggf. vorhandenen OST-Datei sucht?
    Das würde vielleicht erklären, warum es mal funktioniert (Exchange Cache ist an) und mal nicht (Exchange Cache ist aus)…

    Antworten
  9. Danke für die Inputs
    Ich habe bei verschiedenen Systemen zusätzlich das Problem, dass die User im gesendeten Elemente die Mails mit einem geschlossenen Briefsymbol angezeigt bekommen.
    Kann da jemand helfen?
    Umgebung A: Office 365 und Exchange 2019
    Umgebung B: Office Standard 2016 und Exchange 2016
    Umgebung C: Office Standard 2016 und Exchange 2019

    Antworten
  10. Mahlzeit,

    bei EX2016 können nach dem Update im OWA keine Anhänge mehr heruntergeladen werden…hat da jemand einen Workaround oder müssen wir einfach auf MS warten?

    Antworten
    • Liest du normalerweise die Release notes? Das stand von Anfang an dabei, dass nach der Installation die Download Domains Funktion nicht mehr geht. Also wirst du sie bis zum Fix deaktivieren müssen. Wie das geht, hat ms sogar gleich mit im Artikel verlinkt. Schau mal nach. :)

      Antworten
      • Ich hab’s in der Tat überlesen, ja…ist aber auch nicht Kriegsentscheidend solange die Mitarbeiter aufs Outlook ausweichen können…dass das Briefsymbol im Outlook anders angezeigt wird, ist hier eher das Problem für die Mitarbeiter…kann aber auch sein, dass das nur bei Office 2019 auftritt, da testen wir noch…

        Antworten
  11. Ich hatte das Update gestern Abend installiert und prompt kam heute morgen der erste User und meinte die Suche im Outlook funktioniert nicht mehr.
    Was ich nun ohne die Registry Keys festgestellt habe, eine Zahl kann ich suchen, einen Namen nicht! *LOL*
    Werde mal bei Gelegenheit die Registry Keys setzen, den ich befürchte bis zu dem Fix von MS kann es noch dauern.
    Danke für die Info hier!

    Grüße,
    Holger

    Antworten
  12. Wir haben den Fehler auch schon seit dem CU 14. Aber danke für den Hinweis mit dem Registry Eintrag. Dieser scheint bei mir lokal schonmal zu funktionieren. :)

    Antworten
  13. Hallo,

    ich habe das CU auf einem unserer Testserver installiert. Die bereits bekannten Probleme im OWA traten auf.
    Ich habe nun das Problem, dass ich das SU nicht wieder deinstallieren kann. Es wird ein Installationsmedium verlangt. Die .msi aus den letzten CUs werden nicht akzeptiert.
    Über Powershell mit WUSA /UNINSTALL /KB:5036401 kommt die Ausgabe, dass das Paket nicht installiert ist.
    Hat jemand eine Idee?

    Antworten
    • Moin,

      ich habe diesen Fall soeben auch durchlebt. Ich habe einfach die ISO von CU14 in das DVD Laufwerk eingebunden um darauf verwiesen.
      Das Setup ist dann bei mir zwischenzeitig hängen geblieben, da habe ich dann noch den Windows Defender einmal deaktiviert.
      Danach ist das Setup durchgelaufen und das Security Update wurde erfolgreich deinstalliert.

      Antworten
      • Danke für den Hinweis mit dem Defender. Die Deinstallation hat nun funktioniert. Ich hatte dieses mal die ISO des CU14 vorab eingebunden und den Defender deaktiviert. Dieses mal wollte der Deinstallationsprozess aber kein Installationsmedium haben. (wtf?) und die Deinstallation lief durch.

        Antworten
  14. Betrifft das Problem mit der Suche nur Umgebungen, die noch Postfächer OnPrem haben oder auch Umgebungen, die alle Postfächer in der Cloud haben?

    Antworten
  15. Dieses DisableServerAssistedSearch als Workaround hatten wir doch erst vor ein paar Jahren im Sommer als workaround für ein problematisches Office Update?

    Security Updates verschieben ist halt nun auch so eine Sache… puh…

    Antworten
    • Schon richtig, aber wenn’s so viel kaputt macht ist einem ja auch nicht geholfen. Ich werde auch noch etwas abwarten und hoffen, dass die zeitnah einen Fix bringen.

      Antworten

Schreibe einen Kommentar