Exchange Server verschickt keine OOF-Mails nach Migration

Ein Leser hat mich auf ein Problem hingewiesen, bei dem ein Exchange Server nach einer Migration keine OOF-Mails (Out-of-Office, Abwesenheitsnachrichten) mehr verschickt hat. Netterweise wurde die Lösung des Problems auch gleich mitgeschickt, daher dieser kleine Artikel. Ich denke das Problem dürfte nicht allzu häufig auftreten und der Fehler lässt sich auch nicht mehr ganz rekonstruieren, aber vielleicht hilft es ja noch jemanden weiter.

Die Situation war folgende: Nach dem Abschluss einer Exchange Migration und der Deinstallation des alten Servers, wurden für keine Benutzer mehr OOF-Mails versendet. Der Abwesenheitsassistent lies sich zwar problemlos aktivieren, jedoch erhielten interne sowie externe Benutzer keine OOF-Mails.

Ursache des Fehlers war eine falsche Gruppenzugehörigkeit des neuen Exchange Servers. der neue Exchange Server war Mitglied der Gruppe “ExchangeLegacyInterop”:

Exchange Server verschickt keine OOF-Mails nach Migration

Wie die Beschreibung der Gruppe schon verrät, sollten hier eigentlich nur Computerkonten von Exchange 2003 Servern enthalten sein:

This group is for interoperability with Exchange 2003 servers within the same forest. This group should not be deleted.

Ich könnte mir vorstellen, dass dieses Problem aufgetreten ist, weil alte Computerkonten wiederverwendet wurden. Wie schon erwähnt, lässt sich der Fall nicht mehr genau rekonstruieren, es wäre aber folgendes denkbar:

  1. Es gab früher einen Exchange 2003 Server mit dem Hostnamen “Exchange”
  2. Der Exchange 2003 Server wurde zu Exchange 2010 mit dem Hostnamen “Mailserver” migriert
  3. Nach der Migration wurde Exchange 2003 deinstalliert oder manuell aus dem AD gelöscht, das Computerkonto wurde allerdings nicht gelöscht sondern verblieb im AD
  4. Bei der Migration von Exchange 2010 zu Exchange 2016 wurde nun wieder der Hostname “Exchange” verwendet, hiermit wieder das alte Computerkonto des Exchange 2003 Server reaktiviert und war damit auch Mitglied der Gruppe “ExchangeLegacyInterop”.

Ob dies nun der Fall war, oder ob das Computerkonto manuell zur Gruppe hinzugefügt wurde, lässt sich nicht mehr klären.

Nachdem das Computerkonto des Exchange 2016 Servers aus der Gruppe “ExchangeLegacyInterop” entfernt wurde und der Dienst “MSExchangeTransport” neugestartet wurde, funktionierten auch die OOF-Mails wieder problemlos. Zur Sicherheit kann hier aber auch ein Neustart des Servers nicht schaden. Die Gruppe “ExchangeLegacyInterop” sollte also leer sein und keine Mitglieder haben, wenn keine älteren Exchange Server mehr im Einsatz sind.

Der neue Exchange Server kann übrigens keine OOF-Mails versenden, weil der Gruppe “ExchangeLegacyInterop” zwei Berechtigungen auf den Empfangsconnectoren “Default” und “Default Frontend” verweigert werden:

Exchange Server verschickt keine OOF-Mails nach Migration

Ich würde hier allerdings nicht die Berechtigungen der Connectoren anpassen, sondern lieber das Computerkonto aus der Gruppe nehmen.

2 Replies to “Exchange Server verschickt keine OOF-Mails nach Migration”

  1. Und was tun wenn externe Domains interne Abwesenheitsnotizen bekommen :-)?

    Hast du hierfür evtl auch einen Ansatz?

    Danke & LG

  2. Oof funktioniert, nur die gesendete Mail (egal ob Intern oder extern) landet machmal nicht im Postfach sondern in der Poison Queue obwohl die Postfachregel nur besagt das die Mail weitergeleitet werden sollte.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.