Exchange Reporter 2.2 veröffentlicht

Gerade habe ich den Exchange Reporter 2.2 veröffentlicht. Diesmal gibt es einige neue Module und mehrere Fehlerkorrekturen

Hier die Zusammenfassung der Änderungen:

  • Neues Modul
    • careport.ps1 – Informationen zur Zertifizierungsstelle und Zertifikaten
    • pfreport.ps1  – Informationen zur Öffentlichen Ordnern
    • dgreport.ps1 – Listet ungenutzte Verteilerlisten auf
    • HPiLOReport.ps1 – Liest Information zu HP Servern aus
  • Bugfix: Rechtschreibfehler behoben
  • Bugfix: -Installpath Parameter wird nicht mehr zwingend benötigt, das Script ermittelt den Pfad selbst
  • Änderungen an mailreport.ps1
    • Top 10 Sender/Empfänger nach Volumen
  • Änderungen an mbxreport.ps1
    • Funktion für Postfächer nahe dem Sendelimit verbessert
  • Änderungen an redirectreport.ps1
    • Alphabetische Sortierung (Danke Daniel!)
  • Änderungen an dbreport.ps1
    • Farbliche Kennzeichnung wenn Backup älter als 7 Tage (Danke Daniel!)
  • Dokumentation überarbeitet (allerdings noch nicht perfekt)

Exchange Reporter 2.2 kann hier runtergeladen werden, Feedback ist wie immer erwünscht.

Vielen Dank an Daniel K. der mich auf Probleme hingewiesen hat und sogar Verbesserungen mit eingebracht hat (siehe oben)

17 Kommentare zu “Exchange Reporter 2.2 veröffentlicht”

  1. Vielen Dank für die neue Version, deines super Tools!

    Folgende Error’s habe ich im Log nach Aktualisierung auf die neue Version:

    pfreport.ps1
    Der Parameter „Date“ kann nicht gebunden werden. Der Wert „08.05.2015 23:00“ kann nicht in den Typ „System.DateTime“ konvertiert werden. Fehler: „Die Zeichenfolge wurde nicht als gültiges DateTime erkannt.“

    careport.ps1
    Die Benennung „get-ca“ wurde nicht als Name eines Cmdlet, einer Funktion, einer Skriptdatei oder eines ausführbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist (sofern enthalten), und wiederholen Sie den Vorgang.

    Hast Du einen Tipp dazu?

    Gruß, Steffen

  2. Danke für die Erweiterungen!
    Leider bekomme ich beim iLO Check einen Fehler.

    Auszug aus ErrorLOG.txt:

    Die Benennung „Get-HPiLOServerInfo“ wurde nicht als Name eines Cmdlet, einer Funktion, einer Skriptdatei oder eines ausführbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist (sofern enthalten), und wiederholen Sie den Vorgang.

    Beste Grüße Franz

  3. Auch bei mir will der pfreport nicht.

    pfreport.ps1
    Cannot bind parameter ‚Date‘. Cannot convert value „11.05.2015 22:25“ to type „System.DateTime“. Error: „String was not recognized as a valid DateTime.“

  4. Hi,

    @Franz
    Du musst wahrscheinlich noch ein Modul laden. Siehe „Exchange Report Handbuch“ Seite 8 bei HPiLOReport.ps1.

    @Frank
    im oabreport würde ich folgende Änderung Vorschlagen:
    Zeile 16 löschen und Zeile 17 wie folgt abändern:
    $UNCOABPath = „\\$($OABVirtualDirectory.Server)\“ + „$(($LocalOABPath).Replace(„:“,“$“))“
    In unserer Umgebung ist Exchange nämlich nicht auf C: installiert und so hast du diese Stelle dynamisch.

    Der Fehler im pfreport ist recht simple.
    Es gibt zwei Variablen die angepasst werden müssen in Zeile 15 und 17 muss jeweils aus $lastbackup –> $pflastbackup gemacht werden. Damit ist der Fehler behoben.

    Gruss Daniel

  5. Danke für das Update, klasse :)
    Könnte man ggf. einbauen wieviele ActiveSync Geräte activ sind zusätzlich zu den inaktiven?

    @Daniel K.: Habe die Änderungen so eingetragen und es läuft klasse!

  6. Hi Frank!

    Vielen Dank für die Aktualisierung des Tools.

    Leider kann ich es nicht ausführen. Wenn ich es manuell aufrufe erhalte ich beim Punkt „Erstelle temporäres Verzeichnis“ den Status Fehler.

    Das TEMP Verzeichnis bleibt leer (habe in der settings.ini den Wert CleanTMPFolder=nein gesetzt). Obwohl der Wert „WriteErrorLog=ja“ gesetzt ist, erhalte ich keine Log Datei.

    Vielen Dank im Voraus!

    LG, Michael

    1. Hallo Michael,

      das TEMP Verzeichnis darf nicht existieren wenn Exchange Reporter ausgeführt wird. Es wird zur Laufzeit angelegt und nach Abschluss auch wieder gelöscht.

      Gruss, Frank

      1. Hi Frank!

        Vielen Dank für deine Antwort. Habe das Verzeichnis gelöscht, funktioniert nun aus einer PS Session wie es soll. Nun kämpfe ich noch mit dem Task Scheduler. Wenn ich das Script darüber ausführe, erhalte ich immer 0x1 als Error Code.
        Der Task wird mit „highest privileges“ ausgeführt. Grundsätzlich alles gleich wie in der alten Version….. mal sehen ;)

        LG, Michael

  7. Hi Frank,

    wollte mich nochmal bei dir bedanken! Nun läuft alles wie es soll!

    Tolle Arbeit. Weiter so!

    LG & Schönen Abend,
    Michael

  8. Hi Frank,

    mir ist das bisher nie aufgefallen (habe mir extra die alten Reports auch mal angeschaut), aber ich sehe leider keinen Outlook-Client der zugreift:

    Client Übersicht
    Übersicht Outlook Versionen

    Outlook 2003 Outlook 2007 Outlook 2010 Outlook 2013 Andere Version
    Keine Outlook Benutzer gefunden

    Woran könnte das denn liegen?
    Clients haben bisher über RPC/HTTP zugegriffen, seit Freitag über MAPI/HTTP – hat aber bei beiden Varianten keine Clients angezeigt. Die ActiveSync Clients zeigt mit das Script einwandfrei an.

    An der Stelle auch vielen Dank für die tolle Arbeit! Weiter so!
    Viele Grüße

    Uwe

  9. Hi Frank,

    habe es selbst herausgefunden: Mein Vorgänger hat an unserem Exchange die Variable für den „msExchDataPath“ im ADSIedit auf ein anderes Laufwerk geändert, damit neue Mailboxen direkt auf diesem angelegt werden. Habe ihn wieder auf den Ursprung zurückgestellt und jetzt funktioniert es ;-) Kann man das nicht einfacher über die PATH-Variable „ExchangeInstallPath“ abfragen? Die LOG-Verzeichnisse um die es geht liegen ja in der Regel immer darin.

    Wenn jemand sonst noch das Problem hat, vielleicht hilft ihm diese Info ja.

    Viele Grüße

    Uwe

  10. Der neue Report sieht sehr gut aus aber leider macht er im Gegensatz zum 2.1 noch ein paar Fehler :-(
    Hier der Auszug aus der Errorlog
    addsinfo.ps1
    Der RPC-Server ist nicht verfügbar
    mbxreport.ps1
    Der Wert „8.382 GB (9,000,564,411 bytes)“ vom Typ „Microsoft.Exchange.Data.Unlimited`1[[Microsoft.Exchange.Data.ByteQuantifiedSize, Microsoft.Exchange.Data, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]“ kann nicht in den Typ „System.Double“ konvertiert werden.
    careport.ps1
    Die Benennung „get-ca“ wurde nicht als Name eines Cmdlet, einer Funktion, einer Skriptdatei oder eines ausführbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist (sofern enthalten), und wiederholen Sie den Vorgang.
    -Ende— 05/19/2015 11:35:49 —————————————————————-

    Dummerweise habe ich die PSPKI Installation schon gemacht :-(

    VG
    Andreas

    1. Hi Andreas,

      hast du PSPKI für alle Benutzer installiert? Für addsinfo musst du enable-psremoting auf den DCs auführen. Die Sache im MBX Report schaue ich mir noch einmal an.

      Gruss, Frank

  11. Super Tool jedoch bekomme ich kein Ergebnis bei dem Report mbxreport.ps1
    Fehlermeldung siehe nachfolgend
    mbxreport.ps1
    Es ist nicht möglich, eine Methode für einen Ausdruck aufzurufen, der den NULL hat.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.