Neue Exchange Reporter Version (3.5)

Nachdem ich am 27.06.2019 eine neue Version des Exchange Reporters veröffentlicht hatte, wurden in der jetzt aktuellen Version 3.6 noch ein paar Bugs behoben. Hier eine Übersicht der Änderungen:

  • Neue Funktionen
    • FTP Upload Funktion (Danke an Daniel)
  • Bugfixes
    • Rblreport: Blacklist bl.spamcannibal.org entfernt, da nicht mehr existent
    • VmwareReport: PowerCli wird nun als Modul geladen (Dank an Steffen)
    • SSLReport: Falsche Zeile wurde in bestimmten Fällen in den SSLReport eingefügt, da eine Variable doppelt verwendet wurde
    • KempReport: Der KempReport wurde überarbeitet und funktioniert nun mit den aktuellen Loadmaster Versionen (getestet mit Version 7.2.46)
    • Dokumentation angepasst
  • Hinweise
    • Es gab Änderungen an der settings.ini (FTP Upload), bitte die aktuelle Version anpassen und nutzen

Vielen Dank geht auch an Steffen und Daniel. Daniel hat eine Funktion beigesteuert, welche es ermöglicht den Report auch via FTP auf einen Server zu veröffentlichen. Steffen hatte darauf hingewiesen, dass die PowerCLI nicht mehr als PowerShell Snapin, sondern als Modul geladen wird.

Wer den Exchange Reporter noch nicht kennt, findet hier einen exemplarischen Screenshot:

Neue Exchange Reporter Version (3.5)

Eine Beschreibung von Exchange Reporter, den Funktionen und den aktuellen Download gibt es hier:

Von der Veröffentlichung des Reporters bei Github habe ich erst einmal Abstand genommen, zu diesem Thema habe ich bisher keine Rückmeldungen erhalten und für mich ist es zunächst einfacher mit lokalen Versionen zu arbeiten. Falls hier aber verstärkt Anforderungen eingehen, werde ich dies noch einmal überdenken.

5 Kommentare zu “Neue Exchange Reporter Version (3.5)”

  1. Hallo Frank,

    wie ist die richtige Konfiguration, wenn nur O365 abgefragt wird, bzw. was mache ich falsch?
    In der settings.ini habe ich „OnlyUseOffice365“ auf yes gesetzt und im Abschnitt „Office365“ die Zugangsdaten eingegeben.

    Wenn New-ExchangeReport ausgeführt wird, tritt bei Loading global Variables ein Fehler auf.
    In ErrorLog wird folgendes protokolliert:

    Die Benennung „Set-ADServerSettings“ wurde nicht als Name eines Cmdlet, einer Funktion, einer Skriptdatei oder eines ausführbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist (sofern enthalten), und wiederholen Sie den Vorgang.

    Vielen Dank im Voraus.
    Grüße

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.