Exchange 2016: Systempostfächer neu erstellen

Oft werden Probleme mit den Systempostfächern erst bemerkt, wenn neue Exchange Server installiert werden sollen, meistens bricht die Installation dann ab.

Fehlerhafte Systempostfächer können auch auftreten, wenn eine Datenbank gelöscht wurde, welche die Postfächer enthielt. Normalerweise verwindet Exchange das Löschen einer Datenbank, wenn noch Systempostfächer vorhanden sind. Im Falle einer korrupten Datenbank, die manuell aus dem Active Directory gelöscht wurde, greift der Exchange 2016 Sicherungsmechanismus allerdings nicht.

Die Systempostfächer lassen sich allerdings relativ einfach neu Erstellen. Für dieses Beispiel habe ich daher die Datenbank gelöscht, die die Postfächer enthalten hat. Das Resultat sind defekte Systempostfächer:

get-mailbox -Arbitration
get-mailbox -AuditLog

Systempostfächer

Die Postfächer könnten in diesem Fall zwar einfach in eine neue Datenbank verschoben werden, aber es könnte ja auch mal Probleme mit den dazugehörigen AD-Konten geben. Daher werden die Systempostfächer komplett neu angelegt.

Im Active Directory werden dazu die folgenden 6 Konten gelöscht:

image

Die Ausgabe der beiden oben angegebenen Befehle ist nun leer:

image

Jetzt kann das Exchange Setup mit dem Parameter “/PrepareAD” gestartet werden. Dazu kann direkt in der Exchange Management Shell in das Exchange BIN Verzeichnis gewechselt werden und setup.exe aufgerufen werden:

cd $exbin
Setup.exe /PrepareAD /IAcceptExchangeServerLicenseTerms

image

Setup kann auch von einem anderen Exchange Server oder direkt aus dem ISO aufgerufen werden. Bei einem ISO ist wichtig, dass mindestens die Gleiche oder eine höhere Cumulative Update Version verwendet wird.

Setup hat nun die gelöschten Benutzerkonten wieder angelegt:

image

Für die Konten müssen nun wieder Postfächer angelegt werden:

Enable-Mailbox –Arbitration –Identity "FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042"
Enable-Mailbox –Arbitration –Identity "SystemMailbox{1f05a927-172e-4567-8642-ee1a6510c594}"
Enable-Mailbox –Arbitration –Identity "SystemMailbox{bb558c35-97f1-4cb9-8ff7-d53741dc928c}"
Enable-Mailbox –Arbitration –Identity "SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}"
Enable-Mailbox –Arbitration –Identity "FederatedEmail.4c1f4d8b-8179-4148-93bf-00a95fa1e042"
Enable-Mailbox -Arbitration -Identity "Migration.8f3e7716-2011-43e4-96b1-aba62d229136"
Enable-Mailbox –AuditLog –Identity "SystemMailbox{8cc370d3-822a-4ab8-a926-bb94bd0641a9}"

image

Zu guter Letzt wird noch der Anzeige Name auf “Microsoft Exchange” geändert und das Sendelimit für die entsprechenden Postfächer angepasst:

Get-Mailbox -Identity "SystemMailbox{e0dc1c29*" -Arbitration | Set-Mailbox -Arbitration -DisplayName "Microsoft Exchange"
Get-Mailbox -Arbitration -Identity "FederatedEmail*" | Set-Mailbox -Arbitration -ProhibitSendQuota 1MB
Get-Mailbox -Arbitration -Identity "Migration*" | Set-Mailbox -Arbitration -ProhibitSendQuota 300MB

image

Fertig, die Systempostfächer sind wieder einsatzbereit:

image

7 Gedanken zu „Exchange 2016: Systempostfächer neu erstellen“

  1. Hallo Frank,
    für das Migrationspostfach ist nach meiner (leidvollen) Erfahrung noch
    Set-Mailbox „Migration.8f3e7716-2011-43e4-96b1-aba62d229136“ -Arbitration –Management:$true
    nötig, sonst laufen alle Verschiebungen auf den Fehler:
    The migration mailbox for the organization is either missing or invalid.
    Zumindest klappte es danach bei mir :-)

    Antworten
  2. Hallo Frank,
    wirklich sehr gute Beschreibung! Hat alles perfekt geklappt.

    @ Peter
    richtig, ohne läuft es nicht. Das war der fehlende Hinweis!

    Vielen Dank an euch beide :)

    Antworten
  3. Ich habe die Systempostfächer nach einem Desaster Recovery mit dem CU11 wieder hergestellt.
    Da traten zwei neue Postfächer auf:
    SystemMailbox{2CE34405-31BE-455D-89D7-A7C7DA7A0DAA}
    SystemMailbox{D0E409A0-AF9B-4720-92FE-AAC869B0D201}

    Das CU11 habe ich nicht voll durchgeführt, weil es, wie im anderen Thread beschrieben, abbrach und der Grund für das Desaster Recovery war

    Beste Grüße

    Jörg

    Antworten
  4. Guten Tag,

    ich verzweifel hier. Also das erstellen der Systempostfächer hat alles geklappt. Danke.
    Ich habe eine Transportregel für ein 4 Augen Prinzip. In der Log Datei sehe ich das auch die Genehmigung-Email generiert wird. Aber auch leider ein Event ID Drop statt findet und diese nicht mehr in dem Postfach landen der die Email Genehmigen muss. In einem anderen Exchangeserver läuft alles ohne Probleme. Sehe aber keinen Unterschied.

    Antworten
  5. Ich hänge im Kreis fest, Setup 2016 bricht mit Fehlermeldung ab – wahrscheinlich Systempostfächer defekt, habe sie gelöscht.
    Setup mit /prepareAD bricht mit Meldung ab, man solle zuerst das eigentliche Setup fertig stellen,…
    E:\>Setup.exe /IAcceptExchangeServerLicenseTerms /PrepareAD
    Microsoft Exchange Server 2016, kumulatives Update, unbeaufsichtigte Installation 15
    Dateien werden kopiert…
    Dateikopiervorgang beendet. Setup erfasst nun zusätzliche für die Installation erforderliche Informationen.
    Sprachen
    Postfachrolle: Transportdienst
    Postfachrolle: Clientzugriffsdienst
    Postfachrolle: Unified Messaging-Dienst
    Postfachrolle: Postfachdienst
    Postfachrolle: Front-End-Transport-Dienst
    Postfachrolle: Clientzugriffs-Front-End-Dienst
    Die Voraussetzungen für Microsoft Exchange Server werden überprüft
    Voraussetzungen werden konfiguriert ABGESCHLOSSEN
    Analyse der Voraussetzungen FEHLER
    Vorheriger Fehler beim Installieren der HubTransportRole-Rolle. Führen Sie Setup nur für diese Rolle erneut aus, oder
    entfernen Sie die Rolle mithilfe der Systemsteuerung.
    Weitere Informationen erhalten Sie unter: http://technet.microsoft.com/library(EXCHG.150)/ms.exch.setupreadiness.InstallWatermark.aspx
    Setup von Exchange Server wurde nicht abgeschlossen. Weitere Details finden Sie im Protokoll ‚ExchangeSetup.log‘ im
    Ordner ‚:\ExchangeSetupLogs‘.

    Deinstall geht auch nicht, setup soll erst fertig gemacht werden
    Was nun?

    Antworten
  6. Bei uns hat das Mit dem KU15 zwar geklappt nur jetzt fehlt angeblich ein Systempostfach für den Exchange:
    „Systempostfach ‚6c00da76-7961-4982-879f-96dbc81425af‘ konnte in Active Directory nicht gefunden werden.“
    Wie kann ich das beheben das wird über diesen trick leider nicht mit erstellt.

    Antworten

Schreibe einen Kommentar