Notifications
Clear all

Exchange 2013 CU16 Update auf aktuelle Version  

  RSS

(@tsukaito)
Active Member
Beigetreten: 3 Monaten zuvor
Beiträge: 8
2. März 2020 13:29  

Hallo zusammen,

ich stecke etwas in der Klemme mit meinem Exchange 2013. Folgende Konfiguration für den Server:

  • Server 2012R2
  • Exchange 2013 CU16
  • kein DAG
  • ein Server mit allen Rollen
  • .NET 4.7.1

Ich möchte jetzt auf die aktuelle Version CU23 hochgehen. Dabei müsste ich ja über den CU20 hoch auf CU23 aktualisieren. Mein Hauptproblem ist das installierte .NET 4.7.1 auf dem Server. Diese Konfiguration ist mit CU16 nicht supported. Ich habe zwar keine Probleme mit dem Server aber gut fühlt sich das nicht an. Jetzt habe ich hier folgende Probleme/Fragen:

  1. Wie genau ist der Upgrade-Pfad bis CU23?
  2. Kann ich CU20 installieren, obwohl hier auch kein 4.7.1 supported ist?
  3. Soll ich das .NET 4.7.1 "downgraden" und dann anfangen?
  4. Kann ich mit dem 4.7.1 gleich auf die CU22 und dann noch auf .NET 4.7.2 und CU23?

Ich habe den folgenden Eintrag von Franky gefunden: https://www.frankysweb.de/exchange-2013-stolperstein-beim-update-einer-alten-version-auf-das-aktuelle-cu/

Wäre das eine gangbarer Weg?

Vielen Dank für Euren Hilfe und euren Ratschlag!


Zitat
Schlagwörter für Thema
(@tonibert)
Active Member
Beigetreten: 7 Monaten zuvor
Beiträge: 18
3. März 2020 13:33  

Hi,

ich habe den Weg erst letzte Woche in meinem Lab getestet inkl. Installation vom Sicherheitspatch.

Meine Umgebung (Lab) hatte sogar noch einen älteren Stand.

  https://www.frankysweb.de/exchange-2016-kumulative-updates-cu-installieren/

 

Bei der Installation des Patch bin ich noch in die Falle getreten, dass ich den Patch nicht mit einer CMD als Admin ausgeführt habe.

https://www.frankysweb.de/exchange-2016-serverfehler-in-anwendung-owa-und-oder-ecp/amp/

 

Produktiv bin ich gerade in der Planung aber im Lab sah es gut aus.

 

Ich hoffe, dass dir das hilft.

 

Grüße


AntwortZitat
(@tsukaito)
Active Member
Beigetreten: 3 Monaten zuvor
Beiträge: 8
3. März 2020 13:44  

@tonibert

Vielen Dank für die Antwort - schön zu sehen, dass ich nicht alleine bin ?.

Ich bin mir nur nicht sicher, welchen Weg Du meinst? Hast du die einzelnen CUs hochgezogen oder bist du den direkten Weg auf CU23 nach dem Technet-Artikel gegangen?

Ich werde das jetzt auch im Lab mal testen und schauen, was passiert. Danach Backups prüfen und durchziehen! ? 

Vielen Dank und viel Erfolg!

 


AntwortZitat
(@tonibert)
Active Member
Beigetreten: 7 Monaten zuvor
Beiträge: 18
3. März 2020 20:39  

Entschuldige, das habe ich nicht geschrieben.

Ich bin direkt auf CU23 gegangen.

Tipp:

Ich habe mir alle Exchangedieste abgefrage mit

get-service-name msex*|select name,status,starttype

und via Screenshot gespeichert. So kannst/musst du sie nach dem Update dann auch wieder einstellen

Meld dich mal wie es lief.

 

Grüße


AntwortZitat
(@tsukaito)
Active Member
Beigetreten: 3 Monaten zuvor
Beiträge: 8
6. März 2020 10:02  

@tonibert

Vielen Dank für den Tipp mit den Services. Klasse!
Ich habe das direkt Update auf CU23 mal im Testlab, inkl. falscher .NET-Version beim CU16, nachgespielt. Ist alles problemlos durchgelaufen und funktioniert.

Dann werde ich mich am nächsten Wochenende mal an das Live-Update machen! Ich werde berichten, wie es geklappt hat. Falls es daneben geht melde ich mich von den Bermuda-Inseln. ? 

Vielen Dank und schöne Grüße!

 


AntwortZitat
(@tsukaito)
Active Member
Beigetreten: 3 Monaten zuvor
Beiträge: 8
17. März 2020 16:59  

Hallo zusammen,

ich wollte hier noch schnell mal Vollzug melden. Ich habe am vergangenen Wochenende den Sprung von CU16 auf CU23 durchgezogen und es lief überraschend gut. Hier meine Vorgehensweise, die zum erfolgreichen, direkten Update auf CU23 geführt hat:

  1. Schema-Erweiterung auf dem DC mit Schemamaster-Rolle durchgeführt (Achtung auch hier ist .NET 4.7.2 nötig, sonst läuft die setup.exe nicht). Hier habe ich mir mal vor längerer Zeit eine sichere Anleitung geschrieben: ActiveDirectory: Sicheres Schema-Update (ADPREP) mittels Replikations-Pause
  2. SMTP, HTTPS und POP3 auf Firewall im NAT deaktiviert, damit nicht neues reinkommt bzw. rausgeht!
  3. Dokumentation aller Exchange-Dienste! (siehe Tipp von Tonibert)

  4. Nötige Software installiert: .NET 4.7.2 installiert, C++ 2013, C++ 2012

  5. Reboot Server
  6. Alle Exchange-Dienste wieder auf normalen Startart gesetzt, aber NICHT gestartet
  7. Setup CU23 gestartet und durchlaufen gelassen
  8. FERTIG

 

Ich bin dabei über drei Probleme gestolpert, die ich hier noch mitteilen möchte:

  1. Beim Start des Updates wurden Dateien durch den "Netapp SnapManager" blockiert. Dienst beendet, Update läuft!
  2. Nach dem Update meldeten viele HealthProbes Fehler, aber alles lief problemlos. Nach etwas Recherche habe ich herausgefunden, dass sich der Exchange nicht mehr an die Health-Mailboxes anmelden kann (Logon Denied Meldungen im Eventlog unter Exchange -> Health -> ResultProbes). Ich habe mich dann dazu entschlossen die Health-Mailboxes neu zu erstellen (Exchange 2013/2016 Monitoring Mailboxes). Danach lief alles wieder problemlos!
  3. Beim Schema-Update bin ich auf den Fehler "Ldifde.exe Failed to Import Schema file error code 8224" gelaufen. Nach etwas Recherche war mir klar, was das Problem verursacht. Ich habe ganz am Anfang die AD-Replikation pausiert und beim der .NET-Installation war ein Reboot des DCs nötig. Dieser bemerkt den Reboot und die Replikation-Pause und will dann kein Schema-Update machen, bevor die Replikation nicht noch mal gelaufen ist. Als Replikation aktivieren, durchführen und wieder deaktivieren, dann klappt es auch mit dem Schema-Update! ? 

AntwortZitat
(@tonibert)
Active Member
Beigetreten: 7 Monaten zuvor
Beiträge: 18
29. März 2020 11:31  

Danke für dein Feedback!

Bleib gesund :-)


AntwortZitat
Share: