Exchange 2013 und A...
 
Benachrichtigungen
Alles löschen

[Gelöst] Exchange 2013 und ActiveSync

6 Beiträge
2 Benutzer
0 Reactions
2,162 Ansichten
 wt1
(@wt1)
Active Member
Beigetreten: Vor 5 Jahren
Beiträge: 8
Themenstarter  

Hallo zusammen,

zuerst mal finde ich es super, dass es hier jetzt ein Forum gibt.

Zu meinem Problem:
Ich habe zwei Exchange Server 2013 (mittlerweile CU22) auf Windows Server 2012R2 (mit .net Framework 4.7.2) in einem DAG mit ca. 3700 Mailboxen und davor einen KEMP Load Balancer.
Seit mehreren Monaten haben wir das Problem, dass die ActiveSync Connection von Mobilen Geräten nicht mehr funktioniert.
Outlook und OWA funktionieren immer einwandfrei.

Im Eventlog kommt immer wieder, dass das EAS Budget bzw. Limit überschritten wurde.
Im Monitoring kommt dann immer wieder, der ActiveSync Component State kurz auf inactive geht (ca. 5-15min).
Habe mehrmals einen PAL Report laufen lassen, dort ist Exchange Seitig alles ok, es kommen allerdings haufenweise .net Perfomance exceptions

Beide Server sind auf VMware Basis virtualisiert, haben jeweils 72GB RAM, 18vCPUs, HP Storage mit 10k rpm SAS Discs.

Folgendes wurde mittlerweile umgesetzt:

Update auf CU22 (vorher war CU14) und .net Framework 4.7.2
RAM und vCPU erhöhen
Anhebung der Session Limits in der Registry
Erstellen einer Throttling Policy mit erhöhten Werten
Recyling vom IIS ActiveSync App Pool alle 720min (getestet von 30min bis 1440min)
Load Balancer mäßig schaut alles Ok aus, in den Logs sieht man lediglich, dass der jeweilige Exchange out of service geht und er umschaltet.

Ressourcenmäßig sind die Server auch nicht übermäßig ausgelastet.
Es betrifft alle art von Mobile Devices (iOS und Android).

Ich hoffe, dass ich jetzt alles drin habe...
Hatte jemand schon mal ein solch ein Problem?
Oder vielleicht sind die 3700 Mailboxen für die zwei Server zuviel? Leider reicht es Storageseitig derzeit nicht für einen dritten Server im DAG, eventuell wären zwei reine Client Access Server eine möglichkeit?

 

Vielen Dank schon mal, falls wer was weiß.

Schöne Grüße

Wolfgang


   
Zitat
Schlagwörter für Thema
Frank Zöchling
(@franky)
Honorable Member Admin
Beigetreten: Vor 14 Jahren
Beiträge: 512
 

Hallo Wolfgang,

in welchen Abständen tritt das Problem auf? Wieviele Clients sind per ActiveSync verbunden? Lässt sich das Problem an gewisse Situationen festmachen (Backup, Virenscans, etc)? Kannst du einmal das Event aus dem Log posten?

Gruß,

Frank


   
AntwortZitat

 wt1
(@wt1)
Active Member
Beigetreten: Vor 5 Jahren
Beiträge: 8
Themenstarter  

@franky

Hallo Frank,

das Problem tritt eigentlich nur während der Hauptbetriebszeit auf (so zwischen 8 und 17Uhr) und es sind von den 3700 Mailboxen ca. 2000 über ActiveSync verbunden. Backup oder Virenscan können wir ausschließen.
Die CPU/RAM/Storage Auslastung haltet sich in diesem Zeitraum allerdings in grenzen.

Eventlog kommt in kürze.

Schöne Grüße

Wolfgang


   
AntwortZitat
Frank Zöchling
(@franky)
Honorable Member Admin
Beigetreten: Vor 14 Jahren
Beiträge: 512
 

Hi Wolfgang,

die Anzhal der User ist ja schon mal nicht ganz klein, durchaus denkbar dass es irgendwo einen Flaschenhals gibt. Wie schaut es denn auf dem ESX Server aus? CPU Ready Werte ggf. zu hoch? Latenz in Richtung Storage OK? Im Eventlog sollten sich zumindest Einträge finden lassen, wenn Exchange der Meinung ist, dass es Performance Probleme gibt, daher wäre die genaue Fehlermeldung interessant.

Gruß,

Frank


   
AntwortZitat

 wt1
(@wt1)
Active Member
Beigetreten: Vor 5 Jahren
Beiträge: 8
Themenstarter  

Hi, sorry für meine späte Antwort, das ganz hat sich nun mehr oder weniger aufgeklärt:

Es gibt einige hundert Mitarbeiter mit iOS Devices, welche eine selbstgebaute App für Vertriebsleute verwenden. Diese App integriert sich in den iOS Kalender und sendet unmengen an Abfragen an den Exchange Server, wodurch dann das EAS Service kurzzeitig ausfällt.

Vorübergehender Workaround bis die App entsprechend anpgeasst wird: eine Throttling Policy für diese User angelegt und damit EAS stark eingeschränkt.

 

lg

wolfgang

 


   
AntwortZitat
 wt1
(@wt1)
Active Member
Beigetreten: Vor 5 Jahren
Beiträge: 8
Themenstarter  

Ach ja, wir hatten dazu auch einen Case beim Microsoft Professional Support offen, welcher aber nicht wirklich brauchbar war.
Der Engineer hat sich nicht einmal halbwegs irgendwelche Log Files o.ä. angesehen.

Und das beste war: der Engineer hat bei einem Windows 10 Client Windows Mail zum testen eingerichtet (welches über EAS läuft). Dies hat natürlich funktioniert, da die Ausfälle sporadisch auftragen. Der Engineer meinte dann, dass Active Sync funktioniert und der Case geschlossen wird und der Professional Support nicht für Ursachenanalyse da ist.

Also kurz zusammengefasst: den Professional Support von Microsoft kann ich nicht empfehlen.


   
AntwortZitat

Teilen: