SMTP Service an Let...
 
Benachrichtigungen
Alles löschen

[Gelöst] SMTP Service an Lets Encrypt Zertifikat scheitert

2 Beiträge
1 Benutzer
0 Reactions
2,836 Ansichten
(@kidlark)
Active Member
Beigetreten: Vor 4 Jahren
Beiträge: 15
Themenstarter  

Hallo Forum,

ich lasse per wacs LE Zertifikate erstellen und per Skript in den IE importieren. Das funktiniert auch. Dem Zertifikat sollen dann die Dienste IMAP, POP, IE und SMTP zugewiesen werden.

Alle Dienste ausser SMTP werden zugewiesen.

get-exchangeCertificate |ft -autosize

XXXXDA82B1D166356012A0E9D69FBF55E06FXXXX IP.W... CN=mail.kunde-gmbh.com

 

Führe ich

enable-exchangecertificate -thumprint XXXXDA82B1D166356012A0E9D69FBF55E06XXXX  -Service SMTP

erhalte ich keine Fehlermeldung. Im Exchange Management Log sehe ich einen Information, daß das Comandlet ausgeführt wurde.

 

ABER:

In der Sekunde in der ich den SMTP Service zuweise, nimmt den irgendein Mechanismus weg.

Auszug aus dem ExchageManagementLog:

  Enable-ExchangeCertificate
      -Thumbprint "XXXXDA82B1D166356012A0E9D69FBF55E06FXXXX" -Services "SMTP" -Server "mailserver"
      kunde.local/Users/Administrator
       
       
      Remote-ManagementShell-Unknown
      13096 w3wp#MSExchangePowerShellAppPool
       
      5
      00:00:00.0420024
      Vollständige Gesamtstruktur anzeigen: 'False', Standardbereich: 'kunde.local', Konfigurationsdomänencontroller: 'DCS1.kunde.local', Bevorzugter globaler Katalog: 'DCS1.kunde.local', Bevorzugte Domänencontroller: '{ DCS1.kunde.local }'
       
       
       
       
       
       
      False
       
      0 objects execution has been proxied to remote server.
       
       
      0
      ActivityId: fdfe9f11-42c0-4eab-a285-ae2ad309ec6a
      ServicePlan:;IsAdmin:True;
       
      de-DE

 

Im Anwendungs-Log taucht sogar die Meldung auf das ein internes Tranport Zertifikat in kürze (30.7.2019) ausläuft. Das entspricht dem Ablaufdatum des LE Zertifikates

Weiter Einträge bez. der Wegnahme des SMTP Services habe ich nicht gefunden.

Ich benötige dieses Zertifikat für die Hybrid-Stellung zu O365 und das scheitert, da dem Zertifikat kein SMPT-Dienst zugewiesen ist.

Irgendeine Erklärung?

Grüße

Georg

 

Dieses Thema wurde geändert Vor 3 Jahren von KidLark

   
Zitat
(@kidlark)
Active Member
Beigetreten: Vor 4 Jahren
Beiträge: 15
Themenstarter  

Hallo Forum,

nach weiterem Studium von Sucherergebnissen habe ich mit ein SSL Zertifikat von GeoTrust entschieden und in 10 Minuten war ich fertig. Dem Zertifikat konnte ich sofort nach Einspielen den SMTP Dienst zu weisen und den O365 Hybrid Wizzard ohne Probleme durch laufen lassen.

So faszinierend ich die Idee von LE finde. Aber ich habe 8 Stunden Lebenszeit damit verschwendet und das ist es nicht wert.

Fazit Exchange und LE Zertifikate: FINGER WEG!

Grüße

Geog

 


   
AntwortZitat

Teilen: