Benachrichtigungen
Alles löschen

Autodiscover funktioniert nicht bei lokaler Anmeldung am PC  

  RSS

(@raze)
New Member
Beigetreten: Vor 2 Monaten
Beiträge: 1
Themenstarter  

Hallo zusammen,

wir haben das Problem, dass wir es nicht schaffen, den Outlook-Client mit dem lokalen Exchange-Server zu verbinden, wenn der Anwender lokal am PC angemeldet ist.

Bei einem Anwender mit AD-Anmeldung funktioniert es.

Eine Besonderheit bei uns ist, dass die E-Mail-Domain anders lautet als unsere interne AD-Domain.

Meine Vermutung ist, dass bei einer AD-Anmeldung die Verbindung zum Exchange-Server über den SCP-Mechanismus erfolgt.

Dies zeigt auch das Protokoll, wenn man den E-Mail Autokonfiguration-Test von Outlook ausführt.

Ohne AD-Anmeldung funktioniert der SCP-Mechanismus nicht.

Outlook versucht daher die verschiedenen Varianten für die autodiscover-URL.

Problem dabei: die autodiscover-URL wird auf Basis der E-Mail-Domain erstellt, bspw. autodiscover.<E-Mail-Domain>/autodiscover/autodiscover.xml

Unser Exchange-Server enthält aber ja im Namen die AD-Domain, also <name>.<AD-Domain>

Daher habe ich im internen DNS einen SRV-Record für unsere E-Mail-Domain eingerichtet, der auf den internen DNS-Namen des Exchange-Servers lautet:

SRV-Record:

_autodiscover._tcp.<E-Mail-Domain> zeigt auf <name>.<AD-Domain>

Der E-Mail Autokonfiguration-Test von Outlook zeigt folgendes:

Es kommt der Hinweis, dass der angefragte Hostname <name>.<AD-Domain> und die SANs auf dem Zertifikat nicht übereinstimmen, man kann dann aber trotzdem auf "weiter" klicken.

Im Reiter "Protokoll" sieht man, dass eine Umleitung auf den Exchange-Server <name>.<AD-Domain> erfolgt ist, doch dann erscheint die Fehlermeldung, dass der Server nicht gefunden werden kann und Name und Passwort falsch seien.

Kennt jemand das Problem bzw. hat jemand eine Idee, wie man es lösen kann?

Danke vorab

VG, Ralf


Zitat
NorbertFe
(@norbertfe)
Estimable Member
Beigetreten: Vor 3 Monaten
Beiträge: 127
 
Veröffentlicht von: @raze

Eine Besonderheit bei uns ist, dass die E-Mail-Domain anders lautet als unsere interne AD-Domain.

Das ist keine Besonderheit, sondern dürfte weltweit ziemlich häufig vorkommen. Die meisten haben ihr AD noch aus .local Zeiten. ;)

Veröffentlicht von: @raze

Meine Vermutung ist, dass bei einer AD-Anmeldung die Verbindung zum Exchange-Server über den SCP-Mechanismus erfolgt.

Das ist auf jeden Fall so.

Veröffentlicht von: @raze

Problem dabei: die autodiscover-URL wird auf Basis der E-Mail-Domain erstellt, bspw. autodiscover.<E-Mail-Domain>/autodiscover/autodiscover.xml

Ja logisch. Deswegen ist es immer praktisch, einfach Split-DNS zu konfigurieren. Dann stimmt die Adresse auch im internen Netz.

Veröffentlicht von: @raze

Kennt jemand das Problem bzw. hat jemand eine Idee, wie man es lösen kann?

Vermutlich einfach autodiscover korrekt konfigurieren. Von extern seid ihr doch sicher erreichbar, also wäre die Frage, wie denn von extern die Autodiscover Konfiguration aussieht und ob sie funktioniert. Falls ja, baust du das intern einfach identisch und schon sollte es auch mit Geräten die nicht AD Member oder mit lokalen Nutzern funktionieren.

Bye

Norbert


AntwortZitat

Teilen: