Notifications
Clear all

Certificate Assistant: Neue Version  

  RSS

(@stefan74)
Active Member
Beigetreten: 7 Monaten zuvor
Beiträge: 8
29. Dezember 2019 19:59  

Hallo zusammen,

ich bekomme auf einem Server2012r2 mit Exchange 2016 Cu14 folgende Meldung

.\CertificateAssistant_v3_EX2016.ps1 : Das Skript "CertificateAssistant_v3_EX2016.ps1" kann nicht ausgeführt werden,
da es eine #requires-Anweisung für Windows PowerShell 5.0 enthält. Die für das Skript erforderliche Version von
Windows PowerShell stimmt mit der derzeit ausgeführten Windows PowerShell-Version 4.0 nicht überein.
In Zeile:1 Zeichen:1
+ .\CertificateAssistant_v3_EX2016.ps1
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : ResourceUnavailable: (CertificateAssistant_v3_EX2016.ps1:String) [], ScriptRequiresExcep
tion
+ FullyQualifiedErrorId : ScriptRequiresUnmatchedPSVersion

kann man 5.0 nachinstallieren oder geht das Script nicht auf einem Server2012R2

Gruss

Stefan


Zitat
Frank Zöchling
(@franky)
Admin
Beigetreten: 10 Jahren zuvor
Beiträge: 303
29. Dezember 2019 22:50  

Hi Stefan,

ändere mal die erste Zeile im Script zu "#requires -version 4.0". Ich habe das Script allerdings nicht mit der PowerShell 4 getestet.

Gruß,

Frank


AntwortZitat
(@stefan74)
Active Member
Beigetreten: 7 Monaten zuvor
Beiträge: 8
2. Januar 2020 08:49  

@franky

Hi,

dann bekomme ich folgenden Fehler

PS C:\data> .\CertificateAssistant_v3_EX2016.ps1
31.12.2019 08:53:43 - System - Info - Geting system parameters
31.12.2019 08:53:43 - System - Info - Certificate Assistant Exchange 2016 Version
31.12.2019 08:53:43 - System - Info - PowerShell Version: 4.0 OSVersion: 6.3.9600.0
31.12.2019 08:53:43 - Check Posh-ACME - Info - Check if Module installed
31.12.2019 08:53:43 - Check Posh-ACME - Warning - Posh-ACME not installed, try to install it
31.12.2019 08:53:43 - Check Posh-ACME - Info - Using legacy installation method
31.12.2019 08:53:43 - Check Posh-ACME - Info - Try to download PackageManagement-MSI Path: C:\data\poshacme.zip
31.12.2019 08:53:43 - Check Posh-ACME - Error - Installation failed or arborted
31.12.2019 08:53:43 - Load Posh-ACME - Info - Posh-ACME is installed, try to load it
Import-Module : Das angegebene Modul "C:\data\Posh-ACME-master\Posh-ACME\Posh-ACME.psm1" wurde nicht geladen, da in
keinem Modulverzeichnis eine gültige Moduldatei gefunden wurde.
In C:\data\CertificateAssistant_v3_EX2016.ps1:173 Zeichen:4
+       Import-Module $PSScriptRoot\Posh-ACME-master\Posh-ACME\Posh-ACME.psm1
+       ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ResourceUnavailable: (C:\data\Posh-AC...\Posh-ACME.psm1:String) [Import-Module], FileNot
   FoundException
    + FullyQualifiedErrorId : Modules_ModuleNotFound,Microsoft.PowerShell.Commands.ImportModuleCommand

 

Gruss

Stefan


AntwortZitat
Share: