Benachrichtigungen
Alles löschen

Versenden der Mails von meiner HP über Office365-SMPT klappt einfach nicht - was überseh ich??

  RSS

(@pibaer)
New Member
Beigetreten: Vor 6 Monaten
Beiträge: 4
Themenstarter  

Hab bei einen Kunden Office365 / Exchange online installiert - klappt soweit alles.
Nun soll die HP über Office365 auch verschicken ( und weiter Apps)

Brauchts da noch Einstellungen im Azure?

in der Powershell kommt das:

$msolcred = get-credential
Send-MailMessage –From office@xxx.at –To ich@yyyy.at–Subject “Test Email” –Body “Test SMTP Relay Service” -SmtpServer smtp.office365.com -Credential $msolcred -UseSsl -Port 587

Send-MailMessage : Für den SMTP-Server ist eine sichere Verbindung erforderlich, oder der Client wurde nicht authentifiziert. Die Serverantwort war: 5.7.57 SMTP; Client
was not authenticated to send anonymous mail during MAIL FROM [VI1PR0302CA0022.eurprd03.prod.outlook.com]

Is SSL nicht sicher Verbindung?

Wie kann ich Wordpress als Client authenifizieren..?

Bin da leider etwas unbewandert - hoff ich hab nix ganz naheliegendes übersehn :)

Danke

Benedikt


Zitat
NorbertFe
(@norbertfe)
Estimable Member
Beigetreten: Vor 4 Monaten
Beiträge: 160
 

Also aussagekräftiger geht die Fehlermeldung doch schon kaum noch.

587 mit TLS will auch eine Authentifizierung. Ob usessl dann tatsächlich tls macht, kann ich dir nicht sagen. TLS und SSL sind halt nicht gleichbedeutend.

WEnn du keine Authentifizierung hinterlegen willst/kannst, dann mußt du über Port 25 (tls) senden und mußt vermutlich dann aber den Host (dein Webserver) in den SPF Record usw. aufnehmen.

Bye

Norbert

Diese r Beitrag wurde geändert Vor 3 Monaten von NorbertFe

AntwortZitat
(@pibaer)
New Member
Beigetreten: Vor 6 Monaten
Beiträge: 4
Themenstarter  

@norbertfe

Hallo Norbert

ja ,stimmt SSL is net TSL - insofern ist diese Abfrage irrelevant; sorry

Aber mein Problem bleibt: auch mit korrekten Angaben in Wordpress (TSL / Port 587/ richtige Credentials) klappt es nicht.
Hat das was mit dem (ergooglten) OAuth zu tun ?

Irgend was brauchts da wohl noch am Exchange online / Azure oder Office 365 um Mails an extern zu verschicken?

Danke

Benedikt


AntwortZitat
NorbertFe
(@norbertfe)
Estimable Member
Beigetreten: Vor 4 Monaten
Beiträge: 160

AntwortZitat
(@pibaer)
New Member
Beigetreten: Vor 6 Monaten
Beiträge: 4
Themenstarter  

Hallo Norbert,

das ist die Fehlermeldung:

Fehler! Die Einstellungen für den eigenen Mail-Server sind möglicherweise fehlerhaft.

Verbindung konnte nicht hergestellt werden.

OHNE modern Authentication

SERVER -> CLIENT: 220 AM0PR10CA0063.outlook.office365.com Microsoft ESMTP MAIL Service ready at Fri, 27 Nov 2020 13:25:49 +0000
CLIENT -> SERVER: EHLO svx9.server.at
SERVER -> CLIENT: 250-AM0PR10CA0063.outlook.office365.com Hello [136.243.x.x] 250-SIZE 157286400 250-PIPELINING 250-DSN 250-ENHANCEDSTATUSCODES 250-STARTTLS 250-8BITMIME 250-BINARYMIME 250-CHUNKING 250 SMTPUTF8
CLIENT -> SERVER: STARTTLS
SERVER -> CLIENT: 220 2.0.0 SMTP server ready
CLIENT -> SERVER: EHLO svx9.easybill.io
SERVER -> CLIENT: 250-AM0PR10CA0063.outlook.office365.com Hello [136.243.x.x] 250-SIZE 157286400 250-PIPELINING 250-DSN 250-ENHANCEDSTATUSCODES 250-AUTH LOGIN XOAUTH2 250-8BITMIME 250-BINARYMIME 250-CHUNKING 250 SMTPUTF8
CLIENT -> SERVER: AUTH LOGIN
SERVER -> CLIENT: 334 VXNlcm5hbWU6
CLIENT -> SERVER: [credentials hidden]
SERVER -> CLIENT: 334 UGFzc3dvcmQ6
CLIENT -> SERVER: [credentials hidden]
SERVER -> CLIENT: 535 5.7.3 Authentication unsuccessful [AM0PR10CA0063.EURPRD10.PROD.OUTLOOK.COM]
SMTP ERROR: Password command failed: 535 5.7.3 Authentication unsuccessful [AM0PR10CA0063.EURPRD10.PROD.OUTLOOK.COM]
SMTP-Fehler: Authentifizierung fehlgeschlagen.
CLIENT -> SERVER: QUIT
SERVER -> CLIENT: 221 2.0.0 Service closing transmission channel
SMTP-Fehler: Authentifizierung fehlgeschlagen.

Anmeldename / Passwort stimmen - siehst du da noch was ??

Dank dir!

Benedikt


AntwortZitat
NorbertFe
(@norbertfe)
Estimable Member
Beigetreten: Vor 4 Monaten
Beiträge: 160
 

Tja sieht für mich aus, als wenn aus welchen Gründen auch immer die Passwortübermittlung irgendwie nicht funktioniert. Ich tippe mal auf deinen Webserver. Im Zweifel machs doch unauth.


AntwortZitat
 cwo
(@cwo)
New Member
Beigetreten: Vor 2 Monaten
Beiträge: 3
 

Nabend Benedikt,

wenn Du TLS mit Port 25 verwendest sollte das soweit laufen. Hatte ich letzte Woche noch bei einer Sophos Messaging Option mit O365.


AntwortZitat

Teilen: