Benachrichtigungen
Alles löschen

[Gelöst] Exchange2019 RecoverServer bricht ab


(@chrismue)
Active Member
Beigetreten: Vor 6 Monaten
Beiträge: 9
Themenstarter  

Hallo zusammen,

ich muss aus gegebenem Anlass einen Exchange neu machen, welcher von dem Hackerangriff befallen war.

Ich halte mich hier an die Anleitung von FrankysWeb.

Die Installation ist jetzt aber schon zweimal abgebrochen.

E:\>Setup.exe /IAcceptExchangeServerLicenseTerms /Mode:RecoverServer
Microsoft Exchange Server 2019, kumulatives Update, unbeaufsichtigte Installation 8
Dateien werden kopiert...
Dateikopiervorgang beendet. Setup erfasst nun zusätzliche für die Installation erforderliche Informationen.
Sprachen
Postfachrolle: Transportdienst
Postfachrolle: Clientzugriffsdienst
Postfachrolle: Postfachdienst
Verwaltungstools
Postfachrolle: Clientzugriffs-Front-End-Dienst
Postfachrolle: Front-End-Transport-Dienst
Die Voraussetzungen für Microsoft Exchange Server werden überprüft
Voraussetzungen werden konfiguriert                                                           ABGESCHLOSSEN
Analyse der Voraussetzungen                                                                   ABGESCHLOSSEN
Microsoft Exchange Server wird konfiguriert
Das Setup wird vorbereitet                                                                    ABGESCHLOSSEN
Dienste werden angehalten                                                                     ABGESCHLOSSEN
Exchange-Dateien werden kopiert                                                               ABGESCHLOSSEN
Sprachdateien                                                                                 ABGESCHLOSSEN
Dienste werden wiederhergestellt                                                              ABGESCHLOSSEN
Sprachkonfiguration                                                                           ABGESCHLOSSEN
Postfachrolle: Transportdienst                                                                ABGESCHLOSSEN
Postfachrolle: Clientzugriffsdienst                                                           ABGESCHLOSSEN
Postfachrolle: Postfachdienst                                                                 ABGESCHLOSSEN
Exchange ManagementTools                                                                      ABGESCHLOSSEN
Postfachrolle: Clientzugriffs-Front-End-Dienst                                                FEHLER
Der folgende Fehler wurde generiert, als "$error.Clear();
set-InstallPathInAppConfig -ConfigFileRelativePath
"FrontEnd\HttpProxy\oab" -ConfigFileName web.config
" ausgeführt wurde: "System.UnauthorizedAccessException: Der
Zugriff auf den Pfad "C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\oab\web.config" wurde
verweigert.
bei System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
bei
System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare
share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean
useLongPath, Boolean checkHost)
bei System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access,
FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy, Boolean useLongPath,
Boolean checkHost)
bei System.IO.StreamWriter.CreateFile(String path, Boolean append, Boolean checkHost)
bei
System.IO.StreamWriter..ctor(String path, Boolean append, Encoding encoding, Int32 bufferSize, Boolean checkHost)
bei
System.IO.StreamWriter..ctor(String path, Boolean append, Encoding encoding)
bei
Microsoft.Exchange.Management.SetInstallPathInAppConfig.InternalProcessRecord()
bei
Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__91_1()
bei
Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean
terminatePipelineIfFailed)
bei Microsoft.Exchange.Configuration.Tasks.Task.ProcessTaskStage(TaskStage taskStage,
Action initFunc, Action mainFunc, Action completeFunc)
bei
Microsoft.Exchange.Configuration.Tasks.Task.ProcessRecord()
bei
System.Management.Automation.CommandProcessor.ProcessRecord()".

Der alte Exchange ist komplett auf C:\ installiert gewesen, daher hab ich den Schalter /targetDir: jetzt nicht verwendet und wollte die DB und die Logs im Nachgang verschieben.

Das ganze läuft in einer Server 2019 Std Umgebung als VM mit 16GB RAM.

Ich weiß nicht das optimale, aber momentan nicht zu ändern.

In dem o.g. OAB Verzeichnis kann ich Dateien erstellen.
Dies hab ich schon getestet. Die Dateien global.asax und web.config.bak wurden auch erstellt.

Kann mir jemand etwas zu dem fehler sagen ?

Im MCSEBOARD habe ich auch schon um Hilfe gefragt.

Gruß

chrismue


Zitat
Frank Zöchling
(@franky)
Admin
Beigetreten: Vor 11 Jahren
Beiträge: 495
 

Hi,

schalt mal die Virenscanner (Defender und ggf. andere ab). Die reagieren aktuell irgendwie etwas allergisch auf das Verzeichnis "C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\oab..." Wodran das wohl liegen mag? ;-)

Gruß,

Frank


AntwortZitat
(@chrismue)
Active Member
Beigetreten: Vor 6 Monaten
Beiträge: 9
Themenstarter  

Hallo Frank,

werd ich morgen mal probieren.

Ist es eigentlkich möglich den Schalter /targetDir trotzdem zu setzen, obwohl vorher alles auf C: installiert war ?

Ich hätte die Installation gerne auf einer anderen Partition.

Gruß

chrismue


AntwortZitat
(@chrismue)
Active Member
Beigetreten: Vor 6 Monaten
Beiträge: 9
Themenstarter  

Hallo Frank,

es war tatsächlich der Defender, der die Installation verhindert hat.

Gruß

chrismue


AntwortZitat

Teilen: