Bin etwas lost- IIS...
 
Benachrichtigungen
Alles löschen

[Gelöst] Bin etwas lost- IIS + Microsoft.Exchange.Http.Proxy.Proxyapplication konnte nicht geladen werden

2 Beiträge
1 Benutzer
0 Likes
192 Ansichten
(@qx44905)
New Member
Beigetreten: Vor 3 Monaten
Beiträge: 2
Themenstarter  

Hallo zusammen,

(Exchange 2019 + CU12)

schon ne weile her als ich das letzte Mal in einem Forum geschrieben habe, also die Verzweiflung ist recht groß.

Angefangen hat es, vermutlich nach nem Update, dass ActiveSync/OWA nicht mehr erreichbar waren. Nach nem kurzen Check gab es einen Fehler mit der web.config datei in dem entspr. Verzeichnis. Ein Doppelter Eintrag konnte nicht hinzugefügt werden, oder so ähnlich. Früher habe ich dieses Problem damit lösen können, dass ich den angegeben Eintrag gelöscht habe - dann lief es wieder.

Nur dieses mal nicht. Letzt endlich bastel ich seit 2 Tagen und habe bereits sämtliche web.config /webshared.config neu erstellt und habe mich dabei etwas verheddert.

Jedenfalls ist das Eventlog voll mit ASP Fehlern, die m.E. den Start der Applikationen verhindern. 

Es geht also weder EMS noch irgendwas anderes. heute Mittag lief zumindest noch Outlook - aber auch das habe ich weggetroubleshootet :-D

Es erscheint folgender Eintrag:

Event code: 3008
Event message: Es ist ein Konfigurationsfehler aufgetreten.
Event time: 28.10.2022 19:44:54
Event time (UTC): 28.10.2022 17:44:54
Event ID: 16b3a96acd4443a38c873b828debc44b
Event sequence: 1
Event occurrence: 1
Event detail code: 0

Application information:
Application domain: /LM/W3SVC/1/ROOT/Rpc-10-133114526944370678
Trust level: Full
Application Virtual Path: /Rpc
Application Path: C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\rpc\
Machine name: QMUC2019-1

Process information:
Process ID: 6284
Process name: w3wp.exe
Account name: NT-AUTORITƒT\SYSTEM

Exception information:
Exception type: HttpException
Exception message: Die Datei oder Assembly "Microsoft.Exchange.FrontEndHttpProxy, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" oder eine Abh‰ngigkeit davon wurde nicht gefunden. Das System kann die angegebene Datei nicht finden. (C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\rpc\web.config line 33)
bei System.Web.Compilation.BuildManager.ReportTopLevelCompilationException()
bei System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled()
bei System.Web.Compilation.BuildManager.CallAppInitializeMethod()
bei System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters, PolicyLevel policyLevel, Exception appDomainCreationException)

Die Datei oder Assembly "Microsoft.Exchange.FrontEndHttpProxy, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" oder eine Abh‰ngigkeit davon wurde nicht gefunden. Das System kann die angegebene Datei nicht finden. (C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\rpc\web.config line 33)
bei System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective)
bei System.Web.Configuration.CompilationSection.LoadAssembly(AssemblyInfo ai)
bei System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig)
bei System.Web.Compilation.BuildProvidersCompiler..ctor(VirtualPath configPath, Boolean supportLocalization, String outputAssemblyName)
bei System.Web.Compilation.ApplicationBuildProvider.GetGlobalAsaxBuildResult(Boolean isPrecompiledApp)
bei System.Web.Compilation.BuildManager.CompileGlobalAsax()
bei System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled()

Die Datei oder Assembly "Microsoft.Exchange.FrontEndHttpProxy, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" oder eine Abh‰ngigkeit davon wurde nicht gefunden. Das System kann die angegebene Datei nicht finden.
bei System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
bei System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
bei System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean forIntrospection)
bei System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
bei System.Reflection.Assembly.Load(String assemblyString)
bei System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective)

Request information:
Request URL: https://qmuc2019-1.club-it.muc:443/rpc/rpcproxy.dll?fd057e35-e6b1-4bff-99d2-bfa750945929@club-it.muc:6001
Request path: /rpc/rpcproxy.dll
User host address: 192.168.200.19
User:
Is authenticated: False
Authentication Type:
Thread account name: NT-AUTORITƒT\SYSTEM

Thread information:
Thread ID: 25
Thread account name: NT-AUTORITƒT\SYSTEM
Is impersonating: False
Stack trace: bei System.Web.Compilation.BuildManager.ReportTopLevelCompilationException()
bei System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled()
bei System.Web.Compilation.BuildManager.CallAppInitializeMethod()
bei System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters, PolicyLevel policyLevel, Exception appDomainCreationException)

 

Wie gesagt, bin mit dem Troubleshooting schon ziemlich durch. Ich vermute, die web.config files sind möglicherweise nicht korrekt.

Vielleicht hat jemand eine Idee oder kann helfen -gern auch gegen Bezahlung, bin schon ziemlich weich in der Birne.

 

 

Viele Grüße

Stephan

 

 


   
Zitat
(@qx44905)
New Member
Beigetreten: Vor 3 Monaten
Beiträge: 2
Themenstarter  

Jungs, er läuft wieder.

Hab auf nem anderen Exchange CU12 installiert und mir alle configfiles kopiert. Nach dem Ersetzen und iisreset alles wieder tutti..

 

LG

Stephan


   
AntwortZitat

Teilen: