Abbruch der CU 18 I...
 
Benachrichtigungen
Alles löschen

Abbruch der CU 18 Installation (Schritt 3 von 11: Verwaltungstools)

4 Beiträge
2 Benutzer
0 Reactions
2,443 Ansichten
(@ssieferer)
New Member
Beigetreten: Vor 4 Jahren
Beiträge: 3
Themenstarter  

Hallo Zusammen,

habe nach den erfolgreichen druchgeführten Vorbereitungen von CU18 (ein Exchange 2016 Server) folgendes Problem:

Die Installation bricht bei "Schritt 3 von 11: Verwaltungstools" mit folgender Fehlermeldung ab:

Der folgende Fehler wurde generiert, als "$error.Clear();

          if (Test-Path ($Env:SystemRoot + "\system32\mmc.exe")) {Copy-Item -Path ($RoleInstallPath+"Bin\mmc.exe.config") -Destination (Split-Path (where.exe mmc)) -Force}

        " ausgeführt wurde: "System.Management.Automation.CommandNotFoundException: Die Benennung "where.exe" wurde nicht als Name eines Cmdlet, einer Funktion, einer Skriptdatei oder eines ausführbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist (sofern enthalten), und wiederholen Sie den Vorgang.

   bei System.Management.Automation.CommandDiscovery.LookupCommandInfo(String commandName, CommandTypes commandTypes, SearchResolutionOptions searchResolutionOptions, CommandOrigin commandOrigin, ExecutionContext context)

   bei System.Management.Automation.CommandDiscovery.LookupCommandProcessor(String commandName, CommandOrigin commandOrigin, Nullable`1 useLocalScope)

   bei System.Management.Automation.ExecutionContext.CreateCommand(String command, Boolean dotSource)

   bei System.Management.Automation.PipelineOps.AddCommand(PipelineProcessor pipe, CommandParameterInternal[] commandElements, CommandBaseAst commandBaseAst, CommandRedirection[] redirections, ExecutionContext context)

   bei System.Management.Automation.PipelineOps.InvokePipeline(Object input, Boolean ignoreInput, CommandParameterInternal[][] pipeElements, CommandBaseAst[] pipeElementAsts, CommandRedirection[][] commandRedirections, FunctionContext funcContext)

   bei System.Management.Automation.Interpreter.ActionCallInstruction`6.Run(InterpretedFrame frame)

   bei System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run(InterpretedFrame frame)

   bei System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run(InterpretedFrame frame)

   bei System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run(InterpretedFrame frame)".

 

Hat hier jemand ein Idee?

Ich wäre sehr dankbar dafür.

 

Vielen Dank und Viele Grüße

Stefan


   
Zitat
(@geloeschter-benutzer)
Reputable Member
Beigetreten: Vor 2 Jahren
Beiträge: 263
 

Hi,

wie hast du das CU18 gestartet? adm. Adm. Commandozeile wäre hier der richtige Weg. Weiterhin, alles an AV Software deaktiviert und auch Backupagenten?

Auch wenns blöd klingt, das CU nochmal komplett runtergeladen? Achte auch drauf, dass keine weiteren User angemeldet sind und definitiv alle Powershellsessions geschlossen sind.

 

Du kannst auch das Exchange Seupt Log live beobachten und dort ggf gleich sehen, was los ist.

 

Gruß,
Monthy 

Diese r Beitrag wurde geändert Vor 4 Jahren von Anonym

   
AntwortZitat

(@ssieferer)
New Member
Beigetreten: Vor 4 Jahren
Beiträge: 3
Themenstarter  

Hi Monthy,

vielen Dank für dein Anwort.

Habe das CU18 setup erst durch Doppelclick gestartet.

Dann aber auch durch:

setup /m:upgrade /IAcceptExchangeServerLicenseTerms

in der Admin Comandozeile.

Beides mal die indentische Fehlermeldung.

Das CU18 neu zu laden habe ich noch nicht versucht (guter Hinweis)

Es waren keine anderen User angenmeldelt und keine Powershell Sessions offen.

Trendmicro ApexOne und Trendmicro Scanmail und Defender waren deaktiviert.

Alle anderen Exchange Zusatztools waren beendet auch die auf anderen Servern laufen (Mailstore, OLX Absence Agent).

 

"Du kannst auch das Exchange Seupt Log live beobachten und dort ggf gleich sehen, was los ist."

Das habe ich noch nicht gemacht (aber gestern davon gelesen)

Veeam Backup kommt ohne einen Agenten aus.

 

Hinweis:

Inzwischen laufen wir auf einer VEEAM Replica (Stand kurz vor der CU18 Installation)

Ein kostenplichtes Ticket bei Microsoft (Business Cirtical - 24/7) wurde nach 14 Stunden noch nicht begonnen.

 

Vielen Dank und viele Grüße

Stefan

 


   
AntwortZitat
(@ssieferer)
New Member
Beigetreten: Vor 4 Jahren
Beiträge: 3
Themenstarter  

Hallo Zusammen,

heute fand ich die Lösung in einer Sandbox Installation:

Der Pfad von CScript war nicht in den Umgebungsvariablen.

Nachdem ich die c:\windows\SysWOW64 in die system path variable aufgenommen habe lief CU18 in der Sandbox durch.

Auch Schritt 3 von 11: Administrationstools problemlos.

 

Ich kam mit dem Trendmicro Support auf CScript, da das Update von Scanmail auch nicht funktionierte.

 

Vielen Dank & Viele Grüße

Stefan

 


   
AntwortZitat

Teilen: