POP3 Authentifizier...
 
Benachrichtigungen
Alles löschen

POP3 Authentifizierungsmetode NTLM steht nicht zur Verfügung

6 Beiträge
2 Benutzer
0 Reactions
3,603 Ansichten
(@joergberlin)
Active Member
Beigetreten: Vor 5 Jahren
Beiträge: 5
Themenstarter  

Auf en Exchange 2016 Server POP3 funktioniert die Verbindung mit NTLM nicht.

Die Fehlermeldung lautet, dass der Server diese Authentifizierungsmethode nicht anbietet. Bei Exchange 2010  funktioniert es „Out of the Box“.

In Open SSL kann man sehen, dass die Authentifizierungsmethode wirklich nicht angeboten wird.

Das interessante ist, dass Exchange 2016 IMAP NTLM unterstützt und auch funktioniert. POP3 funktioniert auf dem 2016 nur mit „Password, normal“.


   
Zitat
Schlagwörter für Thema
(@joergberlin)
Active Member
Beigetreten: Vor 5 Jahren
Beiträge: 5
Themenstarter  

Ich hatte noch vergessen anzugeben, dass ich Exchange 2016 CU12 einsetze.


   
AntwortZitat

Frank Zöchling
(@franky)
Honorable Member Admin
Beigetreten: Vor 14 Jahren
Beiträge: 512
 

Hallo Joerg,

schau mal ob der LoginType auf "SecureLogin" steht (wenn dem so ist, sollte auch NTLM funktionieren):

Get-PopSettings | select logintype

Gruß,

Frank


   
AntwortZitat
(@joergberlin)
Active Member
Beigetreten: Vor 5 Jahren
Beiträge: 5
Themenstarter  

@franky

Vielen Dank für die schnelle Antwort. Folgende Einstellungen wurden an dem Server vorgenommen:

[PS] C:\Windows\system32>Get-PopSettings | fl

RunspaceId : 8400176a-edb5-xxxxx
Name : 1
ProtocolName : POP3
MaxCommandSize : 512
MessageRetrievalSortOrder : Ascending
UnencryptedOrTLSBindings : {[::]:110, 0.0.0.0:110}
SSLBindings : {[::]:995, 0.0.0.0:995}
InternalConnectionSettings : {EX.domain.net:995:SSL, EX.domain.net:110:TLS}
ExternalConnectionSettings : {}
X509CertificateName : mail.domain.de
Banner : POP3 service at ex is ready.
LoginType : SecureLogin
AuthenticatedConnectionTimeout : 00:30:00
PreAuthenticatedConnectionTimeout : 00:01:00
MaxConnections : 2147483647
MaxConnectionFromSingleIP : 2147483647
MaxConnectionsPerUser : 16
MessageRetrievalMimeFormat : BestBodyFormat
ProxyTargetPort : 1995
CalendarItemRetrievalOption : iCalendar
OwaServerUrl :
EnableExactRFC822Size : False
LiveIdBasicAuthReplacement : False
SuppressReadReceipt : False
ProtocolLogEnabled : True
EnforceCertificateErrors : False
LogFileLocation : C:\Logging\Pop3
LogFileRollOverSettings : Hourly
LogPerFileSizeQuota : 0 B (0 bytes)
ExtendedProtectionPolicy : None
EnableGSSAPIAndNTLMAuth : True
Server : EX
AdminDisplayName :
ExchangeVersion : 0.10 (14.0.100.0)

Leider kommt immer noch der Fehler:

Der Server unterstützt die gewählte Authentifizierungsmethode nicht. Bitte ändern Sie die "Authentifizierungsmethode" unter "Konten-Einstellungen | Server-Einstellungen".

Bei dem 2010 geht es mit LoginType : PlainTextAuthentication.

Ich habe die beiden Pop-Dienste neugestartet. Vielleicht übersehe ich hier was?


   
AntwortZitat

Frank Zöchling
(@franky)
Honorable Member Admin
Beigetreten: Vor 14 Jahren
Beiträge: 512
 

Hallo Joerg,

das sieht eigentlich in Ordnung aus. Zumindest sehe ich in der Konfiguration kein Problem. Da du das POP Logging schon aktiviert hast. Schau doch mal in das Logfile, ob sich da ein Problem erkennen lässt. Bzw. poste hier doch mal den Auszug eines Verbindungsversuchs aus dem Log.

Gruß,

Frank


   
AntwortZitat
(@joergberlin)
Active Member
Beigetreten: Vor 5 Jahren
Beiträge: 5
Themenstarter  

Hallo Frank,

entschuldge bitte die Verspätung. Im POP Log stehen keine Anmeldeversuche da der Server die Authentifizierungsmethode nicht anbietet und so keine Verbindung zustande kommt.

Das sieht man auch mit OpenSSL

OpenSSL> s_client -connect EX2016:995 -quiet
depth=2 C = DE, O = BlaBLa OU = BlaBLa-PKI, CN = BlaBla
verify error:num=20:unable to get local issuer certificate
+OK POP3 service at EX2016 is ready.
auth
+OK
PLAIN
.

Beim Exchange 2010 sieht das anders aus:

OpenSSL> s_client -connect EX2010:995 -quiet
depth=2 C = DE, O = BlaBLa OU = BlaBLa-PKI, CN = BlaBla
verify error:num=20:unable to get local issuer certificate
+OK The Microsoft Exchange POP3 service at EX2010 is ready.
auth
+OK
NTLM
GSSAPI
PLAIN
.

Das Problem ist, dass mit Exchange 2013 IMAP und POP über den IIS laufen. Das heißt es wurde neu programmiert.

Damit ist die Authentifizierungsmethode NTLM für POP3 nicht mehr verfügbar.

Aussage Microsoft Support: Thunderbird POP3 with NTLM and Exchange 2016 funktionieren nicht zusammen.


   
AntwortZitat

Teilen: