Exchange 2013 und A...
 
Benachrichtigungen
Alles löschen

Exchange 2013 und ActiveSync

5 Beiträge
3 Benutzer
0 Reactions
255 Ansichten
(@avantus)
Active Member
Beigetreten: Vor 9 Monaten
Beiträge: 4
Themenstarter  

Hallo,

habe ein problem und hoffe das ich hier eine Lösung finde.

 

Haben einen Exchange 2013 laufen (wird bald ersetzt) und haben eine Sophos UTM, mit WAF und ReverseProxy (der Exchange hat intern ein selbstsegniertes Zertifikat und der ReverseProxy eins über Lets Encrypt, der öffentliche Aufruf funktioniert auch und wird auch mit dem Lets Encrypt Zertifikat sauber angezeigt.

Auch wenn ich die Adresse mit /Microsoft-Server-ActiveSync aufrufe, kommt die anmelde maske, was bedeutet, das es durchgereicht wird

Nur haben wir seit etwa mitte Juli das Problem das ActiveSync mit der Outlook App und der Samsung Email App nicht mehr geht, es kommt die Meldung "Fehler bei der Authentifizierung",

aber zb mit der Gmail App wird ActivSync hergestellt.

Hab schon auf den 2 Geräte als verdacht das interne Zertifkat installiert aber ohne wirkung

 

In den Logs kann ich nix konkretes finden oder ich suche an der Falschen stelle

 

WIr haben 15 Mitarbeiter, aber nur 2 nutzen ActiveSync, überlegt eine MDM Lösung für ActiveSync einzuführen, aber für die 2 Geräte meist Overpowered


   
Zitat
NorbertFe
(@norbertfe)
Noble Member
Beigetreten: Vor 4 Jahren
Beiträge: 1470
 

Hast du auf dem Exchange die Extended Protection aktiviert? Falls ja, wäre das durchaus ein Grund, warum es nicht funktioniert.


   
AntwortZitat

(@avantus)
Active Member
Beigetreten: Vor 9 Monaten
Beiträge: 4
Themenstarter  

Hi,

 

nein extended protection ist nicht akiv, hab mal gelesen, das anscheinend einige Email apps mit selbstsignierten Zertifikaten probleme haben, aber sollte doch durch den reverse proxy verschleiert werden oder


   
AntwortZitat
(@dartzen)
Estimable Member
Beigetreten: Vor 3 Jahren
Beiträge: 92
 

Hi,

in einem anderen Thread hier https://www.frankysweb.de/community/exchange2016/android-activesync-problem/#post-6766 gibt/gab es eine ähnliche Diskussion (da war zwar ein Exchange 2016 im Einsatz, aber das ist prinzipiell das gleiche Thema.) Anscheinend hat Samsung in seiner Mail-App die Unterstützung für selbstsignierte Zertifikate abgeknipst. Bei der Outlook App bin ich mir jetzt gerade nicht sicher, ob die das immer noch unterstützen. Zwar sollte durch den Reverse Proxy nur das öffentliche Zertifikat verwendet werden, aber eventuell ist in den Geräten das "interne" auch noch irgendwo im Hintergrund. Ich kenne das noch von Iphones, wenn die Verbindung ursprünglich z.Bsp. im WLAN eingerichtet wurde (und somit das interne Zertifikat als "Vertrauenswürdig" bestätigt wurde) funktioniert es zwar auch von extern mit dem öffentlichen. Aber wenn sich das interne ändert bzw. erneuert wurde, dann hat das immer dazu geführt, dass die Geräte da rumgemeckert haben.

Die vermutlich beste Lösung wäre denke ich, auf dem Exchange das gleiche öffentliche Zertifikat zu benutzen wie in der WAF bzw. im Reverse Proxy. Da haben die Geräte die wenigsten Probleme mit. Dann könntest du zudem auch Extended Protection aktivieren. Dafür muss aber der Server intern natürlich über den gleichen Namen erreichbar sein wie extern, sonst gibt das intern Probleme.


   
AntwortZitat

(@avantus)
Active Member
Beigetreten: Vor 9 Monaten
Beiträge: 4
Themenstarter  

Hallo,

 

eingentlich sollte es mit der Anleitung von Franky "Exchange Zertifikat konfigurieren zb Teil2" funktionieren, wenn ich die virtuelle Adresse, öffentliches Zertifikat und internen DNS Server anpasse ohne eingriffe in die Domäne und Server zu machen oder

 

Danke für eure Hilfe


   
AntwortZitat
Teilen: