Benachrichtigungen
Alles löschen

Migration Exchange 2010 zu Exchange 2016


(@andy2k)
New Member
Beigetreten: Vor 2 Monaten
Beiträge: 4
Themenstarter  

Hallo zusammen,

Ich stehe aktuell vor der Herausforderung einen alten Exchange 2010 Server (Single-Node, keine öffentlichen Ordner etc.) auf Exchange 2016 zu migrieren. Der Server wurde damals von einem externen Dienstleister installiert, bzw. eingerichtet.

Da ich bisher selbst noch keine Migration von Exchange durchgeführt habe und die ganze Umstellung möglichst ohne Ausfälle und Probleme vonstattengehen soll, würde ich mich sehr über eure Unterstützung bei den noch offenen Fragen freuen.


IST-Zustand:

Der Exchange 2010 ist aktuell nur intern über die domain contoso.local erreichbar. Der eigentliche Versand / Empfang der E-Mails, erfolgt über einen SMTP Gateway (Postfix).
Wenn Mitarbeiter von extern ihre E-Mails abrufen/versenden wollen, ist dies also nur via VPN möglich. Daran soll sich auch nach der Umstellung auf Exchange 2016 nichts ändern.

Ich habe bereits einen neuen Server auf Basis von Windows Server 2016 inkl. aller notwendigen Abhängigkeiten installiert.
Sorge bereitet mir aktuell eigentlich nicht nur Autodiscover (aktuell nicht eingerichtet) / Zertifikate.

Aufgrund der „.local“ Domain und der fehlenden Erreichbarkeit von extern, ist eine Split-DNS Konfiguration vermutlich nicht sinnvoll umsetzbar. Welches Vorgehen würdet Ihr empfehlen?


Ich hatte die Umstellung jetzt wie folgt geplant:

- Neues selbst signiertes Zertifikat für Exchange 2016 erstellen und vorab an die Clients verteilen

- Exchange 2016 installieren und direkt im Anschluss die Konfiguration durchführen (Authentifizierungsmethode anpassen, damit es zu keinen Problemen mit der Verbindung kommt.)

- Insofern soweit alles läuft, würde ich dann mit der Migration der Postfächer beginnen.

Gibt es sonst noch etwas zu beachten, was ich eventuell übersehen habe?


Hier noch einige Infos bezüglich der aktuellen Konfiguration:

-> Get-OwaVirtualDirectory | fl *url*
Url : {}
Exchange2003Url :
FailbackUrl :
InternalUrl : https:// ex01.contoso.local/owa
ExternalUrl :

-> Get-ClientAccessServer | fl autodiscover*
AutoDiscoverServiceCN : ex01
AutoDiscoverServiceClassName : ms-Exchange-AutoDiscover-Service
AutoDiscoverServiceInternalUri : https://ex01.contoso.local/Autodiscover/Autodiscover.xml
AutoDiscoverSiteScope : {Default-First-Site-Name}

-> Get-ActiveSyncVirtualDirectory | fl *url*
MobileClientCertificateAuthorityURL :
InternalUrl : https:// ex01.contoso.local/Microsoft-Server-ActiveSync
ExternalUrl :

-> Get-OutlookAnywhere | fl *hostname
Aktuell nicht konfiguriert

-> Get-WebServicesVirtualDirectory | fl *url*
InternalNLBBypassUrl : https:// ex01.contoso.local/ews/exchange.asmx
InternalUrl : https:// ex01.contoso.local/EWS/Exchange.asmx

-> Get-OabVirtualDirectory | fl *url*
InternalUrl : http:// ex01.contoso.local/OAB
ExternalUrl :

Im Voraus vielen Dank für eure Zeit / Unterstützung! :)

LG

Andy


Zitat
NorbertFe
(@norbertfe)
Honorable Member
Beigetreten: Vor 1 Jahr
Beiträge: 552
 
Veröffentlicht von: @andy2k

Neues selbst signiertes Zertifikat für Exchange 2016 erstellen und vorab an die Clients verteilen

Zwar bäh, aber kann man machen.

eigentlich ist das alles relativ easy und ohne Risiko realisierbar. Ob man sich das unbedingt selbst beibringen muss am lebenden Objekt eine andere Frage. Im Zweifel hol dir evtl. Jemanden dazu, der das schon häufiger gemacht hat. Dann ist das schmerzfrei und du lernst es direkt.


AntwortZitat
(@andy2k)
New Member
Beigetreten: Vor 2 Monaten
Beiträge: 4
Themenstarter  

Guten Morgen,

am liebsten hätte ich die Geschichte ja über Split DNS gelöst, aber aufgrund der fehlenden Erreichbarkeit von außen, sehe ich aktuell keinen anderen Weg, als es weiterhin über ein selbst signiertes Zertifikat laufen zu lassen. Ich werde die Installation selbstverständlich vorher in einer Testumgebung durchspielen, mir ging es nur darum eventuell auftauchende Problem im Vorfeld abzuklären.

Habe ich bis auf die von mir genannten Punkte noch etwas übersehen? Für weitere Tipps und Anregungen wäre ich sehr dankbar! :)

Vielen Dank und LG


AntwortZitat
NorbertFe
(@norbertfe)
Honorable Member
Beigetreten: Vor 1 Jahr
Beiträge: 552
 

Was hat denn das Split-DNS mit der externen Erreichbarkeit zu tun? Du kannst Split-DNS auch mit self signed certificates oder auch ohne externe Erreichbarkeit konfigurieren.


AntwortZitat
(@andy2k)
New Member
Beigetreten: Vor 2 Monaten
Beiträge: 4
Themenstarter  

Solange die VPN Verbindung aktiv ist und Outlook eine Verbindung via SCP / Autodiscover herstellen kann sicher richtig. Ich sehe das Problem hier allerdings in der externen Namensauflösung.
Allerdings könnte ich wohl die externe URL einfach auslassen, bzw. am externen DNS nicht konfigurieren, so wie es aktuell ja auch eingerichtet ist.

Welche herangehensweise würden Sie empfehlen? Besser den Weg über ein gültiges Zertifikat und Split DNS gehen?

LG


AntwortZitat
NorbertFe
(@norbertfe)
Honorable Member
Beigetreten: Vor 1 Jahr
Beiträge: 552
 

Und wo siehst du das Problem? Wenns extern den Host gar nicht gibt, ist doch vollkommen egal, ob du da jetzt einen externen Domain Name einträgst oder nicht.

Veröffentlicht von: @andy2k

Besser den Weg über ein gültiges Zertifikat und Split DNS gehen?

Auch das ist am Ende vollkommen egal, aber in Anbetracht der zuletzt bekanntgewordenen Autodiscover"probleme" auf der Clientseite, ists vermutlich sinnvoller trotzdem dafür zu sorgen, dass einem die notwendigen Domains gehören und die Clients ggf. auch eine Antwort bekommen. :) Ich persönlich bin kein Freund von "VPN für alles und alles wird gut", weils eben selten stimmt. Hat aber mit deiner Migration am Ende wenig zu tun, und ob du nun Split-dns oder nicht einrichtest ist auch egal, weil man das jederzeit nachträglich ändern könnte.


AntwortZitat
(@andy2k)
New Member
Beigetreten: Vor 2 Monaten
Beiträge: 4
Themenstarter  

Moin,

Ich habe die Umstellung jetzt mal in einer Testumgebung durchgespielt. Hat soweit auch alles geklappt, allerdings habe ich noch ein Problem mit der Exchange RPC verbindung.

Die URLs sind jetzt wie folgt gesetzt:

Outlook Anywhere
- External: mail.firma.de

Outlook Web App
- Internal: https://mail.firma.de/owa
- External: https://mail.firma.de/owa

Exchange Control Panel
- Internal: https://mail.firma.de/ecp
- External: https://mail.firma.de/ecp

Offline Address Book
- Internal: https://mail.firma.de/OAB
- External: https://mail.firma.de/OAB

Exchange Web Services
- Internal: https://mail.firma.de/EWS/Exchange.asmx
- External: https://mail.firma.de/EWS/Exchange.asmx

ActiveSync
- Internal: https://mail.firma.de/Microsoft-Server-ActiveSync
- External: https://mail.firma.de/Microsoft-Server-ActiveSync

Autodiscover
- AutoDiscoverServiceInternalUri: https://autodiscover.firma.de/Autodiscover/Autodiscover.xml

Ein gültiges externes Zertifikat wurde beantragt, importiert und für die Dienste zugewiesen, zudem wurde Outlook Anywhere aktiviert (NTML).
Leider bekomme ich immer eine Zertifikatswarnung, wenn ich mich mit Outlook verbinden will, da noch immer der alte FQDN vom Server für die "Exchange RPC" Verbindung genutzt wird.

Folgendes gibt der Test der Autokonfiguration aus:

Anzeigename: Mustermann, Max
Interne URL für Outlook Web Access: https://mail.firma.de/owa/
Externe URL für Outlook Web Access: https://mail.firma.de/owa/

Protokoll: Exchange-RPC
Server: ex01.firma.local
Anmeldename: Max.Mustermann
URL für Verfügbarkeitsdienst: https://mail.firma.de/EWS/Exchange.asmx
URL für Abwesenheit: https://mail.firma.de/EWS/Exchange.asmx
URL für Off lineadressbuch: https://mail.firma.de/OAB/a2a148d9-2955-4126-ae12-1 b2f3669f e67/
URL für Unified Messaging-Dienst: https://mail.firma.de/EWS/UM2007Legacy.asmx
Authentifizierungspaket: Keine Angabe
URL für Exchange-Systemsteuerung: https://mail.firma.de/ecp/
Teil-URL für Exchange-Systemsteuerung: ?p=customize/voicemail.aspx&exsvurl= 1
Teil-URLfür Exchange-Systemsteuerung: ?p=personalsettings/EmailSubscriptions.slab&exsvurl=1
Teil-URLfür Exchange-Systemsteuerung: ?p=sms/textmessaging.slab&exsvurl=1

Protokoll: Exchange-HTTP
Server: mail.firma.de
Anmeldename: Max.Mustermann
SSL: Ja
Gegenseitige Authentifizierung: Ja
URL für Verfügbarkeitsdienst: https://mail.firma.de/EWS/Exchange.asmx
URL für Abwesenheit: https://mail.firma.de/EWS/Exchange.asmx
URL für Off lineadressbuch: https://mail.firma.de/OAB/a2a148d9-2955-4126-ae12-1 b2f3669f e67/
URL für Unified Messaging-Dienst: https://mail.firma.de/EWS/UM2007Legacy.asmx
Authentifizierungspaket: NTLM
Name des Zertifikat-Prinzipals: msstd:mail.firma.de
URL für Exchange-Systemsteuerung: https://mail.firma.de/ecp/
Teil-URL für Exchange-Systemsteuerung: ?p=customize/voicemail.aspx&exsvurl= 1
Teil-URLfür Exchange-Systemsteuerung: ?p=personalsettings/EmailSubscriptions.slab&exsvurl=1
Teil-URLfür Exchange-Systemsteuerung: ?p=sms/textmessaging.slab&exsvurl=1
Teil-URL für Exchange-Systemsteuerung: PersonalSettings/DeliveryReport.aspx?exsvurl= 1 &lsOWA= < lsOWA> &MsglD= < MsgIC
Teil-URL für Exchange-Systemsteuerung: ?p=organize/retentionpolicytags.slab&exsvurl= 1

Hab ich bei der Umstellung etwas übersehen?

Vielen Dank im Voraus!

LG


AntwortZitat
(@benny)
Eminent Member
Beigetreten: Vor 1 Jahr
Beiträge: 25
 

Hi

Ich habe auch eine Frage zu Migration EXCH2010 nach EXCH2016

Bei der Deinstallation der alten EXCH2000 Server sehe ich dieser Server immer noch in der ECP Konsole.. Dort stehen Sie nun als bereitgestellte Server.
Außerdem sind die Einträge in der ADSI immer noch enthalten.

Die Deinstallation lief einwandfrei. Wie bekommt man denn diese Einträge sauber raus?

Die Server sind aus der Domäne rausgenommen worden. Die Computerkonten sind jedoch nur deaktiviert. Hat das vielleicht damit noch was zu tun?

Vielen Dank


AntwortZitat

Teilen: