Migration 2010 zu 2...
 
Benachrichtigungen
Alles löschen

Migration 2010 zu 2016 mit Öffentlichen Ordner

5 Beiträge
5 Benutzer
1 Reactions
3,360 Ansichten
(@ttrendel)
Active Member
Beigetreten: Vor 5 Jahren
Beiträge: 5
Themenstarter  

So nun zu meinem Problem.

Habe einen Kunden der eine Exchange 2010 Umgebung mit einem CAS Server und zwei DB Servern hat. Auf jedem DB-Server läuft eine PublicFolder DB mit Replikation. So in diese Konstrukt habe ich nun eine 2016 DAG hinein installiert. Postfächer verschieben und so alles geht.

Nur mit den Öffentlichen Ordnern und der Proxy-Mailbox haut das nicht hin!
Hat der User ein Outlook 2010 geht alles und kann auf die Öffentlichen Ordner zugreifen.
Hat ein User ein Outlook 2016 geht es nicht.

Habe mir das angesehen: https://docs.microsoft.com/en-us/exchange/configure-legacy-public-folders-where-user-mailboxes-are-on-exchange-2013-servers-exchange-2013-help

Auch dies eingerichtet: https://support.microsoft.com/en-us/help/3177600/outlook-can-t-access-public-folders-hosted-on-legacy-exchange-servers#technet

Und noch hier probiert: https://justaucguy.wordpress.com/2017/12/18/outlook-2016-and-exchange-2010-public-folder-woes/

Und zum testen habe ich mir das alles in meiner Labumgebung nachgebaut. Habe es aber nicht zum laufen gebracht.

 

Wenn ich nicht bald eine Lösung dafür finde mache ich eine CASE bei Microsoft dafür aus. Wären es nur ein paar Postfächer hätte man diese mal an einem Wochenende verschoben, aber es sin fast 5000.

Vielleicht hat ja einer von euch eine Idee wie man das lösen kann.

Danke schon mal im voraus. 

 


   
Zitat
(@stevecharon)
New Member
Beigetreten: Vor 5 Jahren
Beiträge: 1
 

Hallo,

ich hatte das Problem ebenfalls. Allerdings erst nach einem Exchange-Update, danach ging es von 2016 aus nicht mehr.

Meine Lösung war tatsächlich die Komplett-Migration. Meine 500+ Postfächer haben auch nur ein paar Stunden gebraucht.

Hängt von Deinem Storage untendrunter ab. Ich hatte mehrere Batches parallel laufen.


   
AntwortZitat

(@badler)
New Member
Beigetreten: Vor 5 Jahren
Beiträge: 1
 

Hallo TTrendel,

habe bei meinen Kunden auch schon beide Varianten gehabt, bei einigen hat das mit der Proxy Mailbox problemlos funktioniert , bei einigen leider nicht. Zuletzt habe ich wirklich stundenlang gesucht und keine Lösung gefunden warum das nicht klappt. Sind dann schlussendlich übers Wochenende umgezogen , was dann problemlos geklappt hat.

Wenn du da was rausbekommst und Microsoft dazu was sagt, wäre es klasse wenn du das dann auch postest.

Herzlichen Dank


   
AntwortZitat
(@geloeschter-benutzer)
Reputable Member
Beigetreten: Vor 2 Jahren
Beiträge: 263
 

Hi,

 

das mit der Proxymailbox wurde ja schon genannt. Wichtig ist auch, dass auf dem EX2010 Server, wo die PF Datenbank(en) liegen, auch eine CAS Rolle installiert ist.

Wenn man also eine Multi Exchange Server Umgebung auf Basis 2010 hat, kann es schon vorkommen, dass es eine Trennung nach CAS und MBX Servern gab. Daher ist es dann wirklich nötig, nachträglich noch die CAS Rolle auf dem(n) Mailboxservern zu installieren, damit das sauber funktioniert. 

Weiterhin muss die Proxymailbox auch der Mailbox des Benutzers zugewiesen sein:

Bsp:

get-mailbox foobar|select default*

DefaultPublicFolderMailbox
--------------------------
<yourdomainhere>/Users/PFProxyMailbox

 

Gruß,
Monthy

 


   
AntwortZitat

Frank Zöchling
(@franky)
Honorable Member Admin
Beigetreten: Vor 14 Jahren
Beiträge: 512
 

Servus,

@Monthy hat die Lösung schon genannt:

If your public folders are on servers that are running Exchange Server 2010 or a later version, you must install the Client Access server (CAS) role on all mailbox servers that have a public folder database. You must also enable Outlook Anywhere on all public folder servers. This allows the Microsoft Exchange RpcClientAccess service to run so that all clients can access public folders.

Quelle: https://docs.microsoft.com/de-de/exchange/configure-legacy-public-folders-where-user-mailboxes-are-on-exchange-2013-servers-exchange-2013-help

Gruß,

Frank


   
AntwortZitat
Teilen: