Exchange 2016 Rever...
 
Benachrichtigungen
Alles löschen

Exchange 2016 Reverse Proxy Apache

2 Beiträge
1 Benutzer
0 Reactions
432 Ansichten
(@graf-pacula)
Trusted Member
Beigetreten: Vor 2 Jahren
Beiträge: 44
Themenstarter  

Hallo zusammen,

 

ich möchte vor unseren EX einen Reverse Proxy auf Apache Basis schalten. Dazu habe ich mir die hier vorliegende Anleitung genommen und umgesetzt. Jedoch kommt es bei den Zertifikat per Lets Encrypt zu Problemen.

Rahmen:  Subdomain srv.domain.de zeigt auf feste ip 80.xxx.xxx.xxx dann Firewall dann RP dann Exchange

Gehostet bei Strato. Der MX-Record zeigt auf die srv.domain.de Der A-Record zeigt auf die feste IP 80.xxx.xxx.xxx. AAAA zeigt auf die STRATO Standard IP.

In der Config für den Apache habe ich die Zeilen für unsere Firma geändert auf:

  • define FrontEndServerName srv.domain.de
  • define FrondEndServerAlias srvdomain.de
  • define FrontEndServerAdmin graf.pacula@domain.de

 

  • define BackEndServerIP 192.xxx.xxx.xxx (Interne IP Exchange Server)

 

Nach dem Editieren der Config habe ich

apache2ctl -t

ausgeführt. Ergebnis: ok

Dann

sudo service apache2 restart

Und anschließend

certbot --apache

Es kommt die Frage, welcher Name verwendet werden soll.

Which names would you like to activate HTTPS for?

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

1: srv.domain.de

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Select the appropriate numbers separated by commas and/or spaces, or leave input

blank to select all options shown (Enter 'c' to cancel):

 

Hier drücke ich ENTER. Und dann kommt der Fehler:

Waiting for verification...

Challenge failed for domain srv.domain.de

http-01 challenge for srv.domain.de

Cleaning up challenges

Some challenges have failed.




IMPORTANT NOTES:

- The following errors were reported by the server:




   Domain: srv.domain.de

   Type:   connection

   Detail: 80.xxx.xxx.xxx: Fetching

    http://srv.domain.de/.well-known/acme-challenge/O7XGuV2c4NkgbSkWdewgwGynMrWoIkWgJlYLH6Kr7LY: 

   Connection refused




   To fix these errors, please make sure that your domain name was

   entered correctly and the DNS A/AAAA record(s) for that domain

   contain(s) the right IP address. Additionally, please check that

   your computer has a publicly routable IP address and that no

Ich vermute mal, dass der AAAA Eintrag Schuld ist. Muß ich hier die feste IP eintragen?

 

Kann hier jemand helfen???????? DANKE schonmal

 

Frank


   
Zitat
(@graf-pacula)
Trusted Member
Beigetreten: Vor 2 Jahren
Beiträge: 44
Themenstarter  

Moin zusammen,

 

auch wenn es sich um einen abgedroschenen Spruch handelt. Er stimmt.

 

Ich hatte das Port Mapping in der FW noch nicht auf den neuen Reverse Proxy für 80/443 umgestellt.

 

Nachdem ich dieses gemacht habe funktioniert alles super. Vielen Dank nochmals für die Anleitung.

 

VG

Frank


   
AntwortZitat

Teilen: