TLS Verschlüsselung...
 
Benachrichtigungen
Alles löschen

TLS Verschlüsselung 1.2

9 Beiträge
2 Benutzer
0 Reactions
1,042 Ansichten
(@delta21)
Active Member
Beigetreten: Vor 3 Jahren
Beiträge: 10
Themenstarter  

liebes Forum, 

 

Kunden sagten mir das Sie keine Mails an mich zustellen können. Über die Webseite CheckTLS.com habe das geprüft in dem ich meine eMail Adresse eingeben habe (SendTo).

Das Ergebnis war das die Mails nicht verschlüsselt warden.

Danach habe ich folgende unternommen:  

  • kommerzielles Zertifikat eingebunden (damit verbunden alle virtuellen Verzeichnisse umbenannt so wie hier beschrieben das ich mail.xxx.xx und autodicover.xxx.xx als Name nutze und ein SAN Zertifikat gekauft)
  • Server 2012 R2 und Exchange Server 2013 aktuellste Sicherheitspatches installiert
  • In Windows die Regedig Werte für für TLS angepasst
  • Den Empfangsconnektor überprüft (TLS war da schon eingeschaltet)

 

Das alles hat nicht zum Erfolg geführt.

Jetzt habe ich noch gelesen das der Servername im Empfangsconnektor auch den neuen Namen haben muss. Bei mir steht da noch Exchange1.xxx.local

So einfach umbenennen lässt er sich aber nicht.

Meine Frage, kann es sein das dies das Problem ist?

Wenn ja wie kann ich den Servername im Empfangsconnector ändern um das mal zu testen


   
Zitat
Schlagwörter für Thema
NorbertFe
(@norbertfe)
Noble Member
Beigetreten: Vor 4 Jahren
Beiträge: 1476

   
AntwortZitat

(@delta21)
Active Member
Beigetreten: Vor 3 Jahren
Beiträge: 10
Themenstarter  

@norbertfe

Vielen Dank für die schnelle Rückmeldung.

Ich habe die Einstellung aus dem Post alle geprüft und auch den FQDN angepasst.  Wenn ich mich intern als auch extern mit telnet verbinde bekomme ich nicht die TLS Option angezeigt - will heißen das die Firewall mal nicht das Problem ist? 

Intern antwortet er auch nicht mit der TLS Option. 

Ich habe mir die Receiveconnector Einstellungen mit der Console angeschaut.  Bei dem Default Frontend Reciver steht unter Banner "220 Firma GmbH" - ist das richtig? müsste da nicht der FQDN stehen? Der Eintrag "TLSCertificateName" ist leer - müsste da nicht der Zertifikatsname stehen? 

Besten Dank vorab für die Unterstützung 


   
AntwortZitat
NorbertFe
(@norbertfe)
Noble Member
Beigetreten: Vor 4 Jahren
Beiträge: 1476
 
Veröffentlicht von: @delta21

Der Eintrag "TLSCertificateName" ist leer - müsste da nicht der Zertifikatsname stehen?

Nein, das ist nicht zwingend notwendig, sondern definiert halt ein bestimmtes Zertifikat wenn mehrere da sein sollten.

Veröffentlicht von: @delta21

Bei dem Default Frontend Reciver steht unter Banner "220 Firma GmbH" - ist das richtig?

Keine Ahnung, wie das dahin kommt. Normalerweise steht da der fqdn des im connector eingetragenen Servers.


   
AntwortZitat

(@delta21)
Active Member
Beigetreten: Vor 3 Jahren
Beiträge: 10
Themenstarter  

@norbertfe

 ja genau, sieht so aus


   
AntwortZitat
NorbertFe
(@norbertfe)
Noble Member
Beigetreten: Vor 4 Jahren
Beiträge: 1476
 

Dann hat wohl mal jemand was konfiguriert.

The Banner parameter specifies a custom SMTP 220 banner that's displayed to remote messaging servers that connect to the Receive connector. When you specify a value, enclose the value in quotation marks, and start the value with 220 (the default "Service ready" SMTP response code).

The default value of this parameter is blank ($null), which uses the following SMTP banner:


   
AntwortZitat

(@delta21)
Active Member
Beigetreten: Vor 3 Jahren
Beiträge: 10
Themenstarter  

@norbertfe 

will heißen ich lösche den Banner und versuche es erneut? 


   
AntwortZitat
(@delta21)
Active Member
Beigetreten: Vor 3 Jahren
Beiträge: 10
Themenstarter  

@norbertfe 

habe jetzt folgenden Banner gesetzt "220 mail.firma.de" 

funktioniert aber immer noch nicht 


   
AntwortZitat

NorbertFe
(@norbertfe)
Noble Member
Beigetreten: Vor 4 Jahren
Beiträge: 1476
 

Lösch doch mal, und stell den default her. Unabhängig davon habe ich im verlinkten thread ja schon geschrieben, dass man das nicht mit dem default connector macht.


   
AntwortZitat
Teilen: